View Full Version : [ubuntu] Upgrade issue: Ubuntu 8.04 to Ubuntu 8.10

November 2nd, 2008, 12:39 PM
I read the other threads on the same topic and didn't find a solution or the same exact problem so am creating a new thread. New here so apologies if I transgress :)

I recently upgraded from a beautifully running Heron to a crippled Ibex :(

As soon as I upgraded and restarted the machine, after the orange logo screen, I get moved to a shell and a command prompt that says,

Gave up waiting for root device. Common problems:
- Boot arguments (cat /proc/cmdline)
- Check rootdelay = (did the system wait too long?)
- Check root = (did the system wait for the right device?)
- Missing Modules (cat /proc/mod/(I can't remember what this was); le/ dev)

Alert! /dev/disk/by-uuid/[long hash string] does not exist. Dropping to a shell!

And then it says: BusyBox something or the other.

I am not very technical adept but have been doing decently with Ubuntu for the last year or so. Still scratching my head trying to figure this out.

Another thing I tried was booting with the .24-21 kernel instead of the new version. There I was able to boot, but into a low graphics low res Ubuntu :(

feeling sad and wanting to move back to Hardy unless someone can help me understand and diagnose this issue.

P.S. I tried the update, upgrade, dist-upgrade thing and that did not work either.


November 2nd, 2008, 01:19 PM
Get into Recovery Mode and try 'xfix'

November 2nd, 2008, 01:28 PM
Will try that now and update the thread. Hope that helps. Thanks :)

November 2nd, 2008, 01:37 PM
'Fix Broken Packages'
'Fix xorg'

November 2nd, 2008, 01:44 PM
worked like a charm on the old kernel. Still doesn't work on .27-7

Didn't understand what u meant by the above instructions ...

Thanks a lot, Pumalite

November 2nd, 2008, 01:52 PM
He means go into recovery mode by selecting the 2.6.27-7 generic (recovery mode) at grub, and selecting the actions he said

November 2nd, 2008, 02:55 PM
Thanks Hazer. If it go into the recovery mode for .27-7 and enter xfix, it says xfix not found. Ibex works perfectly in .24-21 as of now.

Thanks again for the help and patience.

November 2nd, 2008, 05:32 PM
xfix means select fix x server