View Full Version : [ubuntu] palm treo 680

November 1st, 2008, 06:13 AM
I'm sure theres lots of topics like this, but i sorted through about 10 and can't find a situation like mine.

Unlike every other post I read, I cannot initiate the hotsync on my treo device at all using the USB cord. I have tried with gnome-pilot and jpilot. Trying to connect through the usb: /dev/pilot and /dev/USB*

November 1st, 2008, 06:13 PM
Same story for me with my Treo 680. It no longer syncs with my computer since updating to 8.10 from 8.04. Everything used to work beautifully. I have seen reports/comments from lots of other Palm OS users with the same problem with other Palm OS devices too. Hopefully, a fix will be discovered soon.

November 2nd, 2008, 12:21 AM
I have the same problem...no response on my Treo 680 in 8.10 everything was great in 8.04. Help needed please

November 2nd, 2008, 08:52 PM
Same problem here, and it's not funny...

Palm Treo 680
Ubuntu 8.10 (clean install)

November 3rd, 2008, 03:52 PM
Glad I saw this thread. Now I know that this is a common problem for Palm users I can stop wasting time mucking about trying to sort it. Hope a fix appears soon as I can only wait a few days or will have to reinstall Hardy:mad:

November 3rd, 2008, 10:56 PM
Me too! I'm desperate! Please help!

November 4th, 2008, 02:54 AM
I have the same problem. Has anyone reported it in launchpad?

November 4th, 2008, 03:05 AM
You might want to add your details here:

so that the powers that be get on it quick! :)

November 6th, 2008, 12:41 AM
I found the following on Gnome-pilot maillist but being new to ubuntu I cannot sort it out. Can someone have a look and put this in to simple language that someone who is new to ubuntu can understand and use

This is almost certainly due to changes in hal that occurred after the
release of gnome-pilot 2.0.15. This is discussed in gnome bug 484509:

I'm attaching a patch for gpilotd.c that fixes this issue. I should
probably go ahead and release a new version of gnome-pilot to fix this
bug, but you could raise this bug in Ubuntu to bring the issue to the
attention of the Ubuntu maintainer. Debian, for example, patched this
issue last April:

I believe this is the patch

Index: gpilotd/gpilotd.c
================================================== =================
--- gpilotd/gpilotd.c (revision 1547)
+++ gpilotd/gpilotd.c (revision 1548)
@@ -1079,7 +1079,7 @@
hal_device_added (LibHalContext *ctx, const char *udi)
gboolean visor_net = FALSE;
- char *bus, *match_str;
+ char *bus, *platform, *match_str;
int vendor_id, product_id, i;
GPilotDevice *device;
DBusError error;
@@ -1090,15 +1090,23 @@

load_devices_xml ();

- /* HAL match rule: we look for info.bus == 'usb_device'
+ /* HAL match rule: we look for pda.platform == 'palm'
+ * (or the legacy info.bus == 'usb_device')
* and then try to match the usb_device.product_id and usb_device.vendor_id
* against the list in devices.xml.
- if (!(bus = libhal_device_get_property_string (hal_ctx, udi, "info.bus", NULL)))
+ if (platform = libhal_device_get_property_string (hal_ctx, udi, "pda.platform", NULL)) {
+ if (strcmp (platform, "palm") != 0) {
+ libhal_free_string (platform);
- if (strcmp (bus, "usb_device") != 0) {
+ }
+ } else if (bus = libhal_device_get_property_string (hal_ctx, udi, "info.bus", NULL)) {
+ if (strcmp (bus, "usb_device") != 0) {
libhal_free_string (bus);
+ }
+ } else {
+ return;

dbus_error_init (&error);

November 6th, 2008, 07:40 PM
Thanks to who ever provides the updates.

I have just installed todays updatse and my Treo 680 stncs perfectly

Thank you Thank you to the update team:lolflag::lolflag:

November 7th, 2008, 02:29 AM
Hmm. No joy here. My Treo 680 is still not talking with my newly updated Ubuntu 8.10 computer, and I have all of the updates applied that come through the Update Manager. :(

November 8th, 2008, 05:18 AM
Same for me here. My Palm Treo 680 just cannot be connected to my Intrepid 8.10 after upgrading from Hardy 8.04.

November 8th, 2008, 07:43 PM
Running with a freshly installed Ibex with updates, still can't sync.
Can someone please post steps? :(

November 12th, 2008, 09:55 PM
I just installed the latest updates, which I noticed included a new g-pilot application. I was hoping this would be the fix to my syncing problems. Unfortunately, I still don't have syncing with my Treo 680.

Anyone else's working now since the new update?

November 28th, 2008, 08:08 PM
Just to give an update of the status of this, my Treo 680 syncing is working again. Thank you to the Ubuntu team! :)

December 23rd, 2008, 01:21 AM
How did you get your palm to sync? Step-by-step instructions in laymen's terms please.

December 23rd, 2008, 02:02 AM
Update your Ubuntu 8.10 with pre-released updates (intrepid-proposed) by going to System > Administration > Synaptic Package Manager. Click on Updates tab and make sure you tick on Pre-released Updates. Reload your package manager. Your Intrepid will be automatically update with the latest driver for your Palm Treo.

To get your palm to sync: go to System > Preferences > PalmOS device. Click 'Add' to add your device and then 'Get from PDA'. It will sync your Palm with your Ubuntu. In 'Devices' tab, make sure you add a 'USB' type of device.

I notice that my Palm still could not sync with JPilot, but fine with PalmOS. Anybody found the solution on that?