View Full Version : [ubuntu] 8.10 screensaver and mouse

October 31st, 2008, 09:46 PM
I just upgraded hardy to intrepid and noticed an odd change: When a screensaver is active, moving the mouse has no effect. I have to hit a key to bring back the desktop. Is this intentional? Is there a way to bring back the previous behavior?
-- David

November 1st, 2008, 02:25 AM
same issue

November 1st, 2008, 05:48 PM
After my initial post, I upgraded my old Gateway machine (733 MHz, Intel i810 video) to 8.10. This does NOT have the problem. So I tried turning off compiz effects on my newer machine and this did not solve the problem. So now I'm guessing it could have something to do with NVIDIA. Do you by any chance have NVIDIA? I have GeForce 6200 TC and driver v177.

November 3rd, 2008, 02:12 AM
I'm also having the same issue after upgrading to Ibex - mouse movements don't exit the screensaver. Turns out disabling Compiz (desktop effects) fixes it for me, so it may not be an Ibex issue after all (I'd never used compiz in previous Ubuntu versions).

Edit: Cancel that, disabling compiz had nothing to do with it. The screensaver responded to mouse movements when I reduced the activation delay to 1 min and disabled compiz. Now that I've set the delay back to 10 mins, it's unresponsive again - even with compiz still disabled. Interesting.

November 4th, 2008, 09:12 PM
Same issue here. PC stats are:
Intrepid upgraded from Hardy.
NVIDIA graphics card using the NVIDIA driver.
Dell Ubuntu PC.

Is there a bug entered for this in launchpad?

November 4th, 2008, 09:23 PM
Here's the bug: https://bugs.launchpad.net/bugs/273142