View Full Version : [ubuntu] USB mount problems

October 31st, 2008, 08:20 PM
Hi all. I installed Ubuntu eee edition 8.04 on my asus eee last week, and I am having problems using my usb pen drives.
When I plug one of them in a USB port, I get a warning saying that I have to be superuser to mount drive.
This happens even if I try to do a sudo -su command in the terminal. What am I doing wrong? Please not that I only have used Ubuntu for about a week.

regards brint

October 31st, 2008, 08:26 PM
I had the same problem and found it easier to reformat the drives in XP or even 98SE.

Once they were reformatted and plugged into the usb ports, ubuntu found them and they worked like a charm.

If you MUST have them in linux-os, load a LiveCD or GParted LiveCD, set disklabel to msdos, format the drives to ext 2 or 3 and you should be good to go without all the permissions, sudo and such.

October 31st, 2008, 08:47 PM
Hi, thanks for the quick reply. I did a reformat in Vista, and I still get the warning "mount: must be superuser to use mount"
What to do?

November 1st, 2008, 02:12 PM

November 1st, 2008, 05:21 PM
Try making them (or it) work under Ubuntu LiveCD or d/l a GParted LiveCD.
Put the CD in the drive and boot to it. In Ubuntu open System/Admin/Partition Editor. Once GParted loads, on the top right, open the devices "button". Find your device. Right click in the device, select format and go from there.