PDA

View Full Version : [ubuntu] [SOLVED] 8.10 install black screen



Cellwind929
October 31st, 2008, 03:55 AM
Trying to do a fresh install of 8.10. 2.6 p4 celeron on an old mobo with intel integrated graphics. I go to do the live desktop to grab some files off the disks before I reformat and it gets to a black screen with the pointer that I can move, but nothing else. This leads me to believe that X is started but is dying out somewhere. I'm not sure what I can do to resolve it. Is there a command I can run? ctrl+alt+f1 does nothing. All I need to do is be able to install and I don't need compiz and stuff.

andrewwg94
October 31st, 2008, 04:02 AM
Trying to do a fresh install of 8.10. 2.6 p4 celeron on an old mobo with intel integrated graphics. I go to do the live desktop to grab some files off the disks before I reformat and it gets to a black screen with the pointer that I can move, but nothing else. This leads me to believe that X is started but is dying out somewhere. I'm not sure what I can do to resolve it. Is there a command I can run? ctrl+alt+f1 does nothing. All I need to do is be able to install and I don't need compiz and stuff.

same here, they need to fix this quick

Cellwind929
October 31st, 2008, 04:08 AM
Hit f4 and arrow down to safe graphics, try booting with that. I got it to boot into a desktop, not sure if I should install on it though.

edit:640x480 is so small that I cannot see the "next" button to install in the install dialogue.

Cellwind929
October 31st, 2008, 04:33 AM
Ubiquity boots up fine, safe mode starts up fine. Quiting ubiquity and waiting for the live session to start up yields the Ibex wallpaper with an arrow pointer I can move instead of a black background.

Edit: Graphics chipset is 82845G/GL integrated intel

This launchpad bug looks to be it: https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/277699

Cellwind929
October 31st, 2008, 06:26 PM
The problem with X was compiz. I installed, dropped to console, then did a sudo apt-get remove compiz compiz-core.

Restart and things work fine.