View Full Version : [ubuntu] Black Screen of Death/Nvidia/LCD Monitor

October 30th, 2008, 08:01 PM
Way back, ok a couple of years ago I ran into this problem. I have the same problem now.

The wrong video output make my screen switch off.

A couple of years ago this was a pain but I could solve it. Reboot the PC without Xserver and edit xorg.conf. I became quite adept at editing that file, heck I still have the notes. Tell it the horizontal and vertical, and the refresh rate and rez, save the file and bingo it worked.

The devs in their infinite wisdom have developed a system that at no point (that I can find) allows you specify you monitor correctly. almost a "We know best" attitude.

OK my spleen has been vented...a little. I have been at this for hours, searching and reading and trying things out.

Here is the problem:
Ubuntu installs fine, the screen works but I would like to use the restricted drivers for my nVidia graphics card.
I tell it to use the restricted drivers and it appears to install OK. I restart my PC I see the ubuntu progress loading bar. The screen goes black and I hear the tomtoms for the login.

monitor resolution settings thinks my 17"lcd is 18" It has the rez right and the refresh is also wrong. I can find no way of specifying the horizontal KHz & Vertical Hz for an incorrectly detected monitor.

This type of thing has been the bread and butter of setting up a Linux system for as long as I can remember. All good a well that they have a system that can detect 98% of all hardware but to remove the ability to make these changes all together is dumb. Ok, I'm ranting again sorry...

Clean install of 8.10
Intel Core2
BFG 8800GTS 512Mb
LM17N LCD Monitor 17"
Horizontal 31~81KHz
Vertical 56~75Hz

(yes, I have kept the manual)

October 30th, 2008, 08:09 PM
I have almost the same specs as you. What I did was to use the Envy package to install the drivers instead of the ones packaged with the restricted modules.

First thing is to uninstall the restricted driver then open a terminal window and do the following:

sudo apt-get install envyng-gtk

The GTK program is broken so you'll have to run the terminal app (They both do the same exact thing). Run the following:

sudo envyng -t

Follow the prompts and restart. Should be working now.

Edit: Ps if that doesn't work you can always create your own xorg.conf file. Here is the generic one that Nvidia-settings created the first time it ran. (I have a duel monitor setup so you may need to edit this to your liking)...

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@yellow) Mon Oct 13 15:00:58 UTC 2008

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
Screen 1 "Screen1" RightOf "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"

Section "Files"

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"

Section "ServerFlags"
Option "Xinerama" "0"

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "LPL"
HorizSync 30.0 - 75.0
VertRefresh 60.0
Option "DPMS"

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor1"
VendorName "Unknown"
ModelName "ViewSonic VA902b"
HorizSync 30.0 - 82.0
VertRefresh 50.0 - 85.0
Option "DPMS"

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "Quadro FX 1600M"
BusID "PCI:1:0:0"
Screen 0

Section "Device"
Identifier "Device1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "Quadro FX 1600M"
BusID "PCI:1:0:0"
Screen 1

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "DFP: nvidia-auto-select +0+0"
SubSection "Display"
Depth 24

Section "Screen"
Identifier "Screen1"
Device "Device1"
Monitor "Monitor1"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "CRT: nvidia-auto-select +0+0"
SubSection "Display"
Depth 24

October 30th, 2008, 11:11 PM
Thanks for your reply, I have already tried envy with the same results, black screen. I'm not sure that I'm skilled enough to pick through your xorg.conf file to make it my own. What I really need to know is where the information about the monitors kept. Then I might stand half a chance of editing them for my needs.

I have come across one small oddity. I thought I would have a look at nVidia's own installer. It can't be run with Xserver running. What I have found difficult is to get the PC to boot without Xserver. If you go in to recovery, you get a terminal with a blank Xserver desktop. Or a very limited console. Now I'm the first to admit that my command line skills are very limited, but I was unable to navigate through the file system. As I can when I'm working on a terminal window.

October 30th, 2008, 11:43 PM

First off I have figured out how to stop Xserver. At logon Ctrl+Alt+F2 the login.

sudo /etc/init.d/gdm stop

Dose the trick, from there I was able to install the nVidia drivers using nVidia's installer. Again the packages were all installed without a hitch. The result was the same. Black screen of death!

So to recap: the three methods I have tried to make use of the nVidia drivers have resulted in the same Black screen fault.

The built in option to use Restricted Drivers, Envy and nVidia's own install package.

What it feels like is that the drivers are installing correctly. I'm not getting the warning about Xserver having not started correctly. The issue I think is still the monitor not being correctly identified. This plus an inability to put the matter straight by being able to input the information myself.

It could be so simple to put this right, I need it to ask me about the monitor rather than guessing what type of monitor it has!

October 31st, 2008, 12:33 PM
The saga continues... I have been having another look at the xorg.conf file. There is a big note at the top of the file. This time I read it LOL

It says there that additions to the file may be ignored.

Ubuntu must store the information about you monitor somewhere. Can anyone please point me in the right direction?

October 31st, 2008, 01:19 PM
I am not sure if I hace the same problem as you guys.
Firs of all I have dell notebook with Nvidia.

I upgraded ok (had to fix some stuff) but finally did it.
When ubuntu loads, I see loading screen, but as soon as GDM starts, I see black screen, but I can also see ONLY cursor no problem. I also see that screen tries to update or whatever, it keeps...hmm blinking.

Funny thing, if I use KDM or XDM - no problem, but in that case, after login, gnome-desktop does not load. I just have wallpaper and cursos and that's it. No panels, no menus, no CTRL+F2.. nothing. So iguess something is wrong in my case with Gnome desktop or gdm.

November 1st, 2008, 10:38 AM
Thanks for your suggestion, I'll give kubuntu a try. I have nothing against KDE but I have become used to Gnome. I have started to download other distros so I can start testing those. This is all a little disappointing, I have been using ubuntu for the last few years.

I have had to abandoned ubuntu 8.10 on my laptop, because it refuses to work. The laptop has VIA graphics that are not supported therefore I have to run the laptop in low graphics mode. I can't specificy the graphics & monitor during install. Ubuntu is a bit fat for this laptop so I'm having a look at other Distro's. Xbuntu has the same monitor issues. I had a look at gOS but that didn't find the wireless.I'm currently testing Puppy, it all works, if a little primitive.

November 1st, 2008, 11:45 AM
Well I fixed mine (NVidia card), but as I'm pretty inexperienced with Linux I'm not sure it was the best way to do things, but here it is:

Booted into recovery mode and dropped to a root shell
X -configure to generate a new xorg.conf

nano /root/xorg.conf.new to open the new file.
Found "nv" and changed it to "nvidia", then saved and exited nano

cp /root/xorg.conf.new /etc/X11/xorg.confto replace my current xorg.conf

exit then resume boot.
Ubuntu opened in low graphics mode as it couldn't find the Nvidia driver (oops! But at least I have a GUI now)
Tried using restricted driver manager to activate the Nvidia driver but it didn't appear to do anything. So, ran update manager and once up to date downloaded the Nvidia driver from nvidia.com to my desktop.
Restarted into recovery mode/root shell again

cd /home/kohoutec/Desktop

sh NVIDA-Linux-x86-177.80-pkg1.run to start the installer.
When it complained about the run level ignored it and told it to carry on with the installation.
When it asked about checking online for a module said no, and let it compile it's own.
Told it to reconfigure X when it asked. Rebooted.
Yay it works.

Now, as I say this is probably not the best way to be doing things, and god knows what will happen next time there's a kernel update, but for now I'm working....