View Full Version : [kubuntu] Kubuntu Intrepid with Intel video disaster

October 29th, 2008, 07:25 PM
I just upgraded from Kubuntu Hardy to Intrepid on an Inspiron B130 laptop, lspci lists the graphics adapter as an 'Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)'.

In Kubuntu Intrepid, the screen flickers repeatedly, even in KDM. Once KDE4 starts up, the problem continues.. with or without desktop effects being enabled. Also, the screen resolution (1200x800 on this laptop) is not detected, and has to be set manually.

With this flickering problem, KDE4 is unusable on this machine. After I was not able to rectify this issue, I installed XCFE4, and there was no problem.

I still do not understand the purpose in pushing KDE4 on people when it is NOT in a stable condition. So far, I hate KDE4 for a whole list of reasons, but this graphics problems is the most problematic one so far. Thanks KDE, for giving a whole new meaning to the word 'stable'. Sorry for the rant.

If anyone has a clue as to a fix for this issue, it would be much appreciated.

October 29th, 2008, 10:21 PM
Sounds like this issue:


Maybe this fix mentioned at the link above would work?

I can verify what iloman wrote. Disabling that service has stopped the flickering.

For people who cannot find this option:
1. go to System settings in the menu
2. Press the Advanced tab
3. Select the Service Manager
4. Stop the Detecting RANDR(monitor) changes
5. Also tick the checkbox use, so it won't startup again
6. Press apply and close the window

I hope you're flickering is gone now!

October 30th, 2008, 06:42 AM
Many thanks, Mega.

That indeed solved the problem I was having.

November 2nd, 2008, 09:58 PM
Thanks for the tip, this worked on my Acer Aspire 1640 with Intel 915 graphics chip.

I agree this kind of bug/issue should be sorted before release, it seems a very simple problem to avoid.

November 5th, 2008, 01:57 AM
The solution above works on a Acer travelmate 2410 Series

November 5th, 2008, 07:56 AM
I have the same issue but I am running gnome under 8.10

I just noticed that my xorg.conf is missing video info... or am i worng???

# xorg.conf (X.Org X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

# commented out by update-manager, HAL is now used
#Section "InputDevice"
# Identifier "Generic Keyboard"
# Driver "kbd"
# Option "XkbRules" "xorg"
# Option "XkbModel" "pc105"
# Option "XkbLayout" "us"

# commented out by update-manager, HAL is now used
#Section "InputDevice"
# Identifier "Configured Mouse"
# Driver "mouse"
# Option "CorePointer"

# commented out by update-manager, HAL is now used
#Section "InputDevice"
# Identifier "Synaptics Touchpad"
# Driver "synaptics"
# Option "SendCoreEvents" "true"
# Option "Device" "/dev/psaux"
# Option "Protocol" "auto-dev"
# Option "HorizEdgeScroll" "0"

Section "Device"
Identifier "Configured Video Device"

Section "Monitor"
Identifier "Configured Monitor"

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
# commented out by update-manager, HAL is now used
# InputDevice "Synaptics Touchpad"

Joe M

November 5th, 2008, 08:16 AM
DELETED BY XHERO0! I postedit twice here...