View Full Version : [ubuntu] BusyBox 1.1.3 boot error fix for hardy heron Ubuntu 8.04

October 25th, 2008, 04:57 PM
The Issue
The live cd was hanging while booting for installation.
The error when boot disk:
busybox v1.1.3(debian 1:1.1.3-5ubuntu12) built in shell (ash)

Put CD in
boot to install menu
press F6
replace "splash quiet --"
with all_generic_ide pci=routeirq

Note: you may only need to replace "splash quiet --" with all_generic_ide

hit enter

After install:
you need to set "all_generic_ide" in your kernel parameter one more time on first boot after you install.

press esc
press e
go down one row, press e, you are going to edit the kernel boot parameter...
replace "splash quiet --" with "all_generic_ide", no quotes.
press enter
press b

computer should boot up.

after boot up, go into /boot/grub/menu.lst and change the kernel boot option the same way. Each time the updates include a kernel update, you will need to do this..

I have seen this problem on two Dell workstations.

Hope this helps someone.

Note: I believe this works with gutsy also.

April 4th, 2009, 01:06 PM
"all_generic_ide floppy=off irqpoll". What it mean?
"...ide pci=routeirq" what it mean?

October 23rd, 2009, 12:06 PM
Thanks cantormath it worked for me! I was unable to start installation of 8.04(and lower versions) because of BusyBox problem. After applying the changes to options you suggested, i installed ubuntu 8.04. I compiled a new kernel( and it also worked well after doing changed to grub menu(gksudo gedit /boot/grub/menu.lst).

ps: i don't need to do such changes for ubuntu versions higher than 8.04.

March 12th, 2010, 01:15 AM
Same here. The following worked for me http://ubuntuforums.org/showthread.php?p=8952609#post8952609