PDA

View Full Version : [all variants] [SOLVED] Unable to mount my SD card



Aedes
October 23rd, 2008, 06:50 AM
Hello folks. I just installed Ubuntu-eee as an opportunity to learn my way through a full blown Linux operating system. I've got a little experience with Linux based systems but this is my first dedicated machine.
While using the live disk I had no problem opening my SD card, but after installing when I try to open it I get a "Cannot mount volume: Must be superuser to mount." error message. Through the GUI I found the Authorizations section and set the implicit authorizations for the "Mount file systems from removable drives" to yes thinking that would do the trick without any luck. How would I get the system to automatically mount removable media? Terminal commands would be preferable ("sudo apt-get install" is such a wonderful gateway drug into the terminal).

Yoke & Chung
October 23rd, 2008, 07:00 AM
Are you using it on an eee PC?

Hexagoon
October 23rd, 2008, 07:01 AM
Discovered the same problem yesterday, feels like a bug only in ubuntu eee. The solution however, is to create a folder like /media/sd and then mount the memory as root in the terminal.


sudo mkdir /media/sd
sudo mount /dev/sdb1 /media/sd

Then you can browse to /media/sd in nautilus and use the files... Seems like the only way right now :/

panhandle
October 23rd, 2008, 07:05 AM
This is a known problem.

Start here:

http://ubuntuforums.org/showthread.php?t=931755

Also try the eee boards, though I have seen users there referring others to this site.

Aedes
October 23rd, 2008, 07:23 AM
Are you using it on an eee PC?
Yes, I'm using a eeePC 900A.


Discovered the same problem yesterday, feels like a bug only in ubuntu eee. The solution however, is to create a folder like /media/sd and then mount the memory as root in the terminal.


sudo mkdir /media/sd
sudo mount /dev/sdb1 /media/sd

Then you can browse to /media/sd in nautilus and use the files... Seems like the only way right now :/


This is a known problem.

Start here:

http://ubuntuforums.org/showthread.php?t=931755

Also try the eee boards, though I have seen users there referring others to this site.

This did the trick. Thank you both very much.

panhandle
October 23rd, 2008, 07:26 AM
You're welcome. Happy to hear it worked out for you.