View Full Version : [ubuntu] [SOLVED] Permission to mount drive

October 22nd, 2008, 10:50 AM
I can't access my windows ntfs drive through ubuntu.. it says i do not have the permission... what should i do?

October 22nd, 2008, 10:58 AM
Are you able to see it? Is the permission error happening when you're trying to modify files on, or move files to that drive?

Are you trying to mount the drive? I can't remember if ubuntu automatically mounts ntfs drives... If you are trying to mount it, did you remember to sudo/su?

October 22nd, 2008, 11:02 AM
okay...follow this...

go into synaptic package manager and make sure ntfs-3g is installed....

than in terminal type sudo gedit /etc/fstab

in there, add a line like this

/dev/sda1 /media/windows ntfs-3g defaults 0 0

replace "/dev/sda1" with ur partition info... to find thid type sudo fdisk -l in a terminal and it will tell u.

MAKE SURE to create the directory "windows" in the folder "media" on your linux filesystem.

i think this command would do it

sudo mkdir /media/windows

reboot and everything should work...

October 22nd, 2008, 11:12 AM
Does the dialogue offer an "unlock" option. If so click on that put in your password and you will then get access. In my experience having done it once the system remembers next time.

October 22nd, 2008, 11:40 AM
taseedorf's solution worked... thanks :)