View Full Version : [ubuntu] Unable to play .dat files

October 22nd, 2008, 05:55 AM
Hi there.
I'm trying to play a vcd with the extension avseq01.dat.
Can anyone tell me how to make it work?

October 22nd, 2008, 06:42 AM
Dat files are vcd video files in mpeg-1/2 format. Mplayer or vlc will be able to play them

October 22nd, 2008, 06:46 AM
But they don't.
Although I have to say on my computer I have no problems. ( this is me mom's computer )

October 22nd, 2008, 07:23 AM
She is on ubuntu?

Try changing the format from .dat to .mpg/.mpeg and playing in vlc. If that does not work convert the file to avi with ffmpeg or any vidconverter

October 22nd, 2008, 07:28 AM
Yep, and she's celebrating her 60th birthday in two months...
Thanks for the tip, but could you please tell me how to do that?

October 22nd, 2008, 07:34 AM
She might be missing the ubuntu-restricted-extras package and medibuntu repo. Get that and the w32codecs while you're at it.

If nothing works, search synaptic for a video converter.

October 22nd, 2008, 07:37 AM
OK. Thanks.

October 22nd, 2008, 07:40 AM
You could try pressing F2 on the File (to rename it), delete the .dat extension and put in .mpg
See if that works.

October 22nd, 2008, 07:53 AM
Can't copy to my hard drive. See attachment

October 22nd, 2008, 10:43 AM
The CD is probably scratched, so the copy process can't read all data, but you still might be able to play it on the CD itself.

Try this in terminal to see the message:

mplayer avseq01.dat

October 22nd, 2008, 12:21 PM
I'm at my own computer again, but I'll try that when I get there. Btw., I doubt the problem is caused by a scratch, as i can play the cd just fine on my computer, and anyways she can't play any cd's. But thanks again for your advice.

October 23rd, 2008, 05:04 AM
That didn't work.

October 23rd, 2008, 06:16 AM
Hi eternalnewbee,

Install VCDRip/VCDimager from the repos and use:


in a terminal and it will start to transfer the DAT file to your HD as a MPG file.


info vcdrip

for more options.

October 24th, 2008, 04:05 AM
Hi there Dynamo_Joe.
Sorry for my late reply ( no internet connection ).
I installed vdc/imager and ran the command vcdrip, but got the message command not found. Then I ran the command info vcdrip and got this:
What to do next?

October 24th, 2008, 06:23 AM
Sorry, eternalnewbee ... my bad, spelling mistake!

The man pages are here:


1. Put the VCD into your optical drive.
2. Open a terminal and type:


3. It will (automatically) find the drive with the disk in it and start copying the DAT file over to your HD with an MPG extension.

NOTE: Depending on where your were last (that is, in your "home" folder) when you started vcxrip, the MPG will be placed in that directory.

Once again, apologies for the typo and late reply.

October 24th, 2008, 07:41 AM
I'll try that Dynamo_Joe. Unfortunately I'm not at my parents now but will try soon.
Btw. this only solves part of the problem. I should be able to play directly form the cd instead of copying to the hard drive...

October 24th, 2008, 10:08 AM
In vlc or smplayer there is an option "Open VCD". Use it.

October 24th, 2008, 10:14 AM
It doesn't work...

October 25th, 2008, 05:44 PM
Hi eternalnewbee,

Not very good with forums and still learning how to set preferences ... :)

Understand your situation ... VCD support was never great after Dapper, yes, Dapper played VCDs "out of the box" but like I mentioned earlier in another post on another thread, I haven't had time to sort out my Dapper installation (it's still on a 10GB HD somewhere in the study).

Back to your problem, understand that you wish to make it simple for your mother (she is 60) and ideally the media player should start automatically whenever she inserts a VCD into the optical drive.

Some have suggested amending the command in totem (if you google, you'll find you're not the only one with this problem) but it never worked for me.

Sorry if I can't be much more of a help.

October 25th, 2008, 05:54 PM
Hi eternalnewbee,

This thread maybe of help:


October 27th, 2008, 08:33 AM
Didn't work. The solutions from the threads did not apply to this computer. I had already tried them.
EDIT: the command vcdxrip seemed to work, but this was the end result:
<!-- command line used: vcdxrip -->

<videocd class="vcd" version="2.0">


<volume-id>New VideoCD 2.0</volume-id>
<system-id>CD-RTOS CD-BRIDGE</system-id>
<application-id>VOB InstantVideo</application-id>
<publisher-id>The Netmech</publisher-id>




<sequence-item src="avseq01.mpg" id="sequence-00">
<default-entry id="entry-000"/>

October 28th, 2008, 07:15 AM