View Full Version : [ubuntu] Trying to install 8.04 on USB hard drive

October 16th, 2008, 04:20 AM
I'm pretty new to linux, and would like to install 8.04 on my external Western Digital 500 Gb hard drive. I would like to be able to plug in the hd, boot, and be in Ubuntu. When I want Vista, unplug the usb, reboot, and be in Vista.

I blindly installed Ubuntu, putting it on the usb hd, the boot manager (forget what it's called) on the internal drive, and booted to Ubuntu with no problem. When I booted to Vista, it was trashed.

I read an old post on here that said never put the boot manager on the internal hd, so tonight I put it on the usb, booted, and ubuntu said something like can't boot to the partition. I tried using the whole hd as a single partition, and making two separate ones. The computer is a Sony Vaio laptop with 2 Gb RAM. Its BIOS does support booting from an usb hd.

Please help,



October 16th, 2008, 05:41 AM
hey man im trying to do the same thing except with a 4 or an 8 Gb thumb...please tell me when you find out

btw i hope this helps you out



October 16th, 2008, 05:22 PM
Viper1965, while you have your USB drive connected, boot your Live CD, open a terminal (applications > accessories > terminal) and please post:

sudo fdisk -lu
Also, for each of the drives fdisk lists, like sda, sdb, etc, please post the output of:

sudo dd if=/dev/sda count=1 2>/dev/null | strings | grep -ie grub -ie "missing operating system"
So replace "sda" above with each of your drives. And finally, for each command above that returns "GRUB", please post:

sudo dd if=/dev/sda bs=1 skip=1049 count=2 2>/dev/null | hexdump
And replace sda with the drives that previously returned "GRUB". That will greatly clarify what your present setup is as far as booting goes. :)

October 16th, 2008, 08:02 PM
I have had the same problem installing 8.10 from Live USB to a second USB device, (Flash drive).
My problem was that installer saw the Live USB as the first disk and in menu.lst on the destination drive wrote 'root (hd1,0)' when it should have written 'root (hd0,0)'.
If hitting 'Esc' at grub will give you a menu, you can edit this option by pressing 'e', you can test the option by hitting 'b'.
This will not make any permanent changes, but you can edit menu.lst after you are in.

There are linux tools for fixing the MBR in XP but not sure about Vista.

October 18th, 2008, 09:46 PM
Thanks, caljohnsmith, but the first time I booted to the CD, I had no menu at the top of the screen, so I couldn't get to terminal. After that, I could not boot from the CD at all.

Changing hd1 to hd0 worked, C.S. Cameron!!!!!!!! How do you change menu.lst? I opened it, but don't have permissions to save it.Thanks!