View Full Version : [ubuntu] iPod on linux

October 10th, 2008, 12:35 AM
I have been using linux for a while. I just got an iPod and I heard linux supported it. Well the problem is that I get Amarok configured to the iPod but it says that its lockfile or something like that. Is there anything I can do to get it to work?

October 10th, 2008, 12:39 AM
Newer ipods are more tricky then older ones I will warn you, I think most newer ipods need to be jailbreaked before you could use them.

October 10th, 2008, 12:44 AM
SunnyRabbiera is right, you need to see which model you have. My method below works on my 5th/6th generation classic

delete: /media/iPod/iPod_Control/iTunes/iTunesLock (or something similar)

rm -vi /media/iPod/iPod_Control/iTunes/iTunesLock

where iPod is the name of your iPod (mine is Sonic's iPod xD)

the v means to tell you what you're doing and i means prompt for confirmation

If you need to be root:

sudo rm -vi /media/iPod/iPod_Control/iTunes/iTunesLock

October 10th, 2008, 12:48 AM
There is no iTunes Lock. There is iTunesControll but I cant delete it since its a read only. Also I tried gtkpod and it has the same problem

October 10th, 2008, 02:18 AM
I tried the code and it doesnt work