PDA

View Full Version : 8.10 beta -- live broadcast AND playback doesn't work



asaturn
October 7th, 2008, 08:24 PM
but what's weird is it works fine in the ROOT account !?

I know this is in beta, but this seems like a weird issue to be isolated to just the beta... anyone got any ideas?

basically, myth frontend just crashes or seizes up if I try to playback any video from the myth GUI...

but if I try this from the root account, it works fine (but the remote doesn't work in the root account)

halp!

klc5555
October 7th, 2008, 08:38 PM
Maybe the beta screwed up the permissions/ownership of one (or more) of the directories that you record to (?) They all need their ownership and group set to "mythtv" and your user account should be part of the "mythtv" group. The directories themselves probably should have their permissions set to 775.

Just a guess.

Good luck.

asaturn
October 7th, 2008, 08:53 PM
do you know which directories need to have those permissions?

I'll try that... it's a better suggestion than "mythtv crashed. sorry." that the crash app reports... ha

asaturn
October 7th, 2008, 11:48 PM
hey I set the mythtv user directory to be readable by the user account I use for the TV and it fixed it.

thanks!

asaturn
October 8th, 2008, 12:22 AM
ok I take that back, once I applied some more updates and restarted, it crashes again on live TV playback... but recorded TV playback works fine...

what gives? think it messed up the permissions again maybe? I'll check it out ...

Shadowfire
October 8th, 2008, 03:16 AM
I am having the same issue, except it is on version 8.04. I wouldn't doubt if it was permissions still. I will see if I can change mine and see if it fixes it for me..

asaturn
October 8th, 2008, 04:20 AM
I gave in and reinstalled... except this time instead of mythbuntu, I did a full install of ubuntu, got all the updates and set up the video playback to support all formats... got all the plugins, got it the way I want it, then manually installed mythtv. works great - better than before even.

klc5555
October 8th, 2008, 02:37 PM
do you know which directories need to have those permissions?

I'll try that... it's a better suggestion than "mythtv crashed. sorry." that the crash app reports... ha

Sorry I didn't get back to you earlier. By default mythtv (in mythbuntu) records to /var/lib/mythtv/recordings, and/or to whichever other directories (up to 3) you may have set in your default recording group. I usually set these directories to 775. Some people prefer them completely wide open at 777. (Makes me nervous.)

Sometimes, particularly if these directories are in different partitions or disks, either the permissions don't get set on them so that myth can write to the directories, or the ownership & group of one or more of them get set to "root". Or the user may not be a member of the "myth group". If myth (or the myth group) can't write to the directory, playback will work but live TV or recording will just kick the user back to the main menu (or crash).

But it looks as though you're up and running!

All the best! :)