View Full Version : [all variants] Xorg.conf - Proof that files CAN be evil.

October 6th, 2008, 01:55 AM
GARRRR my Xorg hates me more than it hates death.


So, basically my screen is meant to be running at 1280x1024@75.00 hz, which I thought was made rather clear.

Apparently not.

Anyhoo, check out my config.

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder58) Thu Jul 17 18:39:00 PDT 2008

# xorg.conf (xorg X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"

# Uncomment if you have a wacom tablet
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
Identifier "Default Layout"
Screen 0 "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"

Section "Files"

Section "Module"
Load "glx"
Load "v4l"

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Samsung SyncMaster"
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 75.0
Option "DPMS"
ModeLine "1280x1024@75.00" 138.54 1280 1368 1504 1728 1024 1025 1028 1069 -hsync +vsync

Section "Device"
Identifier "Nvidia GFX"
Driver "nvidia"
BoardName "NVIDIA"
Screen 0

Section "Screen"
Identifier "Default Screen"
Device "Nvidia GFX"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Virtual 1400 1050
Depth 24
Modes "1280x1024@75.00"

Cheers all, please respond before I kill someone :P


Edit: Nevermind, i am an idiot. Solved.

December 22nd, 2008, 08:53 AM
Just try to extend the ranges
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 75.0

I had the same and tried to do everything by book. At the end I just did a trial-on-error and ended up with syncs that were "in range" to get the wanted refresh-rate.

But lately with 8.10 and nvidia-settings, it was much easier (in my case).