PDA

View Full Version : [ubuntu] Trouble When Trying To Play Music: "Failed to connect stream: Invalid argument"



NuNn DaDdY
October 5th, 2008, 11:05 PM
This issue just developed itself recently and I'm unsure as to what the problem is. I recently installed wine but I don't think that should have caused the issue. Also I installed the Java Environment so that may have contributed. Any help would be appreciated. Thanks

pah99
October 7th, 2008, 12:30 AM
I also have the exact same error. This happens in Totem, Rythmbox, Mplayer, and Amarok. The only player that works is VLC. This is the terminal output from Totem:
pasha@pasha-laptop:~/Music/Russian/Rock/Lumen/Svoboda$ totem Detki.mp3
** Message: Error: Failed to connect stream: Invalid argument
pulsesink.c(487): gst_pulsesink_prepare (): /play/abin/audiosinkbin/audio-sink/bin4/autoaudiosink1/autoaudiosink1-actual-sink-pulse

When I first installed Ibex, I installed the mp3 codecs and everything worked fine. Then I went and installed a bunch of other stuff, including other codecs. After this it stopped working. In another post it was mentioned that the Dirac BBC codec caused problems, so I uninstalled it, and I still have this problem. So, Not sure what's going on.

Does anyone know what is going on, or is this just a bug in Ibex?

Moog
October 7th, 2008, 12:14 PM
I also have the exact same error. This happens in Totem, Rythmbox, Mplayer, and Amarok. The only player that works is VLC. This is the terminal output from Totem:
pasha@pasha-laptop:~/Music/Russian/Rock/Lumen/Svoboda$ totem Detki.mp3
** Message: Error: Failed to connect stream: Invalid argument
pulsesink.c(487): gst_pulsesink_prepare (): /play/abin/audiosinkbin/audio-sink/bin4/autoaudiosink1/autoaudiosink1-actual-sink-pulse

When I first installed Ibex, I installed the mp3 codecs and everything worked fine. Then I went and installed a bunch of other stuff, including other codecs. After this it stopped working. In another post it was mentioned that the Dirac BBC codec caused problems, so I uninstalled it, and I still have this problem. So, Not sure what's going on.

Does anyone know what is going on, or is this just a bug in Ibex?

Same here. Bug in Ibex. Specifically... the last kernel update.
I think there must be an incompatibility with it and pulse.

You can boot into the previous kernel via the grub menu to confirm this.

I have had this with another kernel upgrade (around 3 revisions back).

You could always file a report at launchpad, but before I could do it last time, a kernel upgrade fixed the issue.

That's the beauty of Beta's.

pah99
October 7th, 2008, 03:41 PM
I tried an older kernel, but it didn't work. I am currently using 2.6.27-5-generic. I tried 2.6.27-4. So, the kernel doesn't seem to be the problem, at least for me.

pah99
October 7th, 2008, 11:10 PM
I have updated to 2.6.27-6-generic. Still no luck.

Moog
October 8th, 2008, 06:27 AM
GOOD NEWS,

Playback has returned this morning (UK) with an update to pulse audio and the pulse hal module.

I still think it was a kernel incompatibility with pulse.

Hopefully it's back for you too.

pah99
October 8th, 2008, 05:12 PM
I have updated twice today(morning and afternoon) and still no luck.

Moog
October 8th, 2008, 08:55 PM
Aaaghh,

It's gone again after the recent updates. OSS works in System -> Preferences -> Sound but this doesn't help with streaming flash video.

Oh well. Roll on the RC on the 23rd, asnd if that fails the 30th for the full release.

pah99
October 10th, 2008, 06:19 PM
The latest kernel update has fixed this for me. I also have flash working correctly with sound.

ArgusVision
October 30th, 2008, 02:24 PM
I'm having the same problem in 8.04. Kernel updates have not fixed it. I don't suppose something like apt-get update pulse would work?
The kinda' strange thing is it is only doing this on my laptop, not my desktop or my wife's laptop. It might be a different app I have installed or hardware differences relating to the kernel.
I'm open to suggestions.

Gonna' search forums and launchpad a little more and post any fix (or a link to the fix)I may find back here.

ArgusVision
October 30th, 2008, 02:42 PM
Hey,

Didn't find any answers in forums, but did think of something kinda' simple.

Went to System >Preferences >Sound and changed the "Music and Movies" setting from "Autodetect" to "ALSA" and guess what...
It worked.

Sometimes its the simple things...

Hope this helps someone.

pah99
November 4th, 2008, 09:10 PM
ArgusVision have you updated to 8.10? If so, has it fixed it for you? After the final version came out I stopped having the problem. So if you still have that problem, try upgrading.

JohQ
November 4th, 2008, 10:15 PM
Thanks ArgusVision, your "trick" worked fine for me :)

For Amarok users (as myself), you have to go to Settings -> configure amarok -> engine -> change Output plugin from Autodetect to the one you prefer using.

naniekso2
November 14th, 2008, 03:40 AM
Thanks It Worked!