PDA

View Full Version : [ubuntu] Nvidia GeForce 8600 GT PROBLEMS! choppy video playback, no compiz, it's a mess!



ggarenn
October 4th, 2008, 09:38 AM
I'm a noob with Linux (I'm sure you get a lot of those here). I decided to install it after my computer crashed and I used an Ubuntu live cd to back up all my info. I love almost everything about Ubuntu, but I'm having so much trouble with my graphics that I have no choice but to go back to Windows - unless I can fix the issues. I used EnvyNG to install the driver for my Nvidia 8600 GT. Then I followed the instructions on this entire thread:

http://ubuntuforums.org/showthread.php?t=766683

I also installed Flash Player 10. Great. Now streaming video has gotten a bit better...youtube videos will actually go to full screen. But will they play? Not really. They freeze up and I'm watching the video at about 1 fps. It's terrible.

Here's what's wrong right now:

- Compiz cannot be enabled ("Desktop effects could not be enabled")

- Can't properly stream videos full screen

- Video playback is low quality & pixelated and I get horizontal lines on the screen during fast-paced movements in the video

I really need some help. Here's what I've done that I can remember...I've installed the gstreamer codecs...java...flash...vlc...and a bunch of other stuff that the aforementioned thread told me to install. But still no luck. What do I do?

Here's some more info:


ggarenn@ggarenn-desktop:~$ lspci -n | grep 0300
05:00.0 0300: 10de:0402 (rev a1)



ggarenn@ggarenn-desktop:~$ glxinfo
name of display: :0.0
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x21 24 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x22 24 dc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x57 32 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None


Sorry it's so long and any help would be appreciated. I'm loving everything else about Ubuntu and it would be awesome if I could keep it around :).

Thanks in advance.

ggarenn
October 4th, 2008, 09:44 AM
PS
Also, I was wondering if there was a way for me to watch streaming shows on ABC.com or NBC.com in Ubuntu...seems like their web players only work in Windows.

klikklak
October 4th, 2008, 10:32 AM
I have the same card and can definitely say that you CAN get it to work. I'm however not a very good instructing people. What you could do is run:
nvidia-xconfig --allow-glx-with-composite

Take a look at /etc/X11/xorg.conf, you want atleast these:
Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection
Section "Screen"
Option "AddARGBGLXVisuals" "True"
Option "NoTwinViewXineramaInfo" "False"
EndSection

I can send you my xorg.conf, but it has some extra stuff for twinview.

ggarenn
October 4th, 2008, 10:56 AM
I edited the xorg.conf file and added both sections. That totally screwed everything up, so I went through recover>xfix and got it back to normal. Then, I added just the Module section. Compiz now says that I need to enable the Nvidia restricted drivers for 3d acceleration...but in my previous experience, doing that has not helped. It has usually made it worse.

Video playback is still crappy.

I would love if you could send me your xorg.conf. If I copy everything over to mine except for the twinview stuff, should my stuff work too? Or is there more involved than just that? Also, I have no idea what the twinview stuff in the conf file would be, so if at all possible it would be great if you could tell me.

klikklak
October 4th, 2008, 03:31 PM
You really need the nvidia-restricted drivers. Try installing and running envyng (envyng -t or -gtk) to get them, then reboot.

Here's the xorg.conf (note that I'm using the nvidia-restricted-drivers)

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder26) Thu Feb 14 18:13:41 PST 2008


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "keyboard"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 110.0
VertRefresh 50.0 - 150.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "True"
Option "MetaModes" "1280x1024, 1280x1024; 1280x1024, ; 640x480, ; 800x600,;1024x768,;"
Option "AddARGBGLXVisuals" "True"
Option "NoTwinViewXineramaInfo" "False"
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

ggarenn
October 6th, 2008, 11:30 AM
Okay, so I got the restricted drivers through Envyng and for the first time ever (even though I've installed the restricted drivers with envyng before) I saw the Nvidia splash screen. So apparently it worked this time. Compiz started to work as well. However, general video playback didn't improve. Neither did streaming. I'm assuming I had all the codecs...but anyway I eventually deleted Ubuntu and went to Vista. I hate Vista, especially after being on Ubuntu for about a week. I'm gonna install Ubuntu on my laptop and play around with it and learn a bit more. I'll make it my main OS as soon as I feel comfortable and confident using it.

Thanks for your help.

klikklak
October 6th, 2008, 11:55 AM
Too bad you're going back to vista, but that's life. You could try installing medibuntu repositories with instructions at http://www.medibuntu.org/ and install the w32codecs or w64codecs.

Milv8
November 19th, 2008, 12:40 PM
Hi All
i have been beating around the bush trying to get desktop enhancements running using a nvidia 8600gt graphics card. the only way i could get it to work was running the codes below. i have nothing in my prepriotary drivers and nvidia xconfig still does nothing.
im happy my 8600gt card is working.

very important you will need to print this out, you will need it.


Print out this guide, you will be in pure CLI for part of the install.

1) Download the driver for your Nvidia Card from http://www.nvidia.com/Download/index.aspx?lang=en-us
1.a) Make sure its in your home directory, this will make it so we don't have to change directories later when were in terminal.

2) Open a terminal: Applications--> Accessories--> Terminal

3) sudo apt-get install build-essential

4) gksudo gedit /etc/modules
4.a) Add "nvidia" without quotes to the list.
4.b) Save and Exit

5) gksudo gedit /etc/default/linux-restricted-modules-common
5.a) Add "nv" without quotes to the restricted list. It should look exactly like this: DISABLED_MODULES="nv"
5.b) Save and Exit

6) sudo cp /etc/X11/xorg.conf ./xorg.conf.backup

7) sudo rm /etc/X11/xorg.conf
7.a) Were just deleting your old xorg.conf file, we backed it up in step 6 just in case we ever need it back again.
7.b) Getting rid of old drivers, use one or more of the sections that apply to you:
-------------------------------------------------------------------------------------------------------
If you used Envy to attempt a previous nvidia install please run this command now before you go on:

sudo envy --uninstall-all
sudo dpkg -P envy

-------------------------------------------------------------------------------------------------------
If you have some old Ubuntu repository/restricted driver manager attempts installed please run this command before you go on:

sudo apt-get remove --purge nvidia*
sudo rm /lib/restricted-modules/.nvidia*

-------------------------------------------------------------------------------------------------------
If you have a failed NVIDIA*.run (drivers from the nvidia.com site) run this command before you go on:

sudo nvidia-installer --uninstall

-------------------------------------------------------------------------------------------------------
################################################## ##################################
##................................................ ................................##
## Alright Now Assuming That You are starting with a clean slate lets move forward##
##................................................ ................................##
################################################## ##################################

8) CTRL-ALT-F1
8.a) Okay were in Command Line only now, we have a little left to do in here.
8.b)login:
8.c)Password:

9) sudo /etc/init.d/gdm stop
9.a) This step shuts down the x-server and gnome desktop manager

10) sudo chmod a+x ./NVIDIA*.run
10.a) We made the nvidia installer executable.

11) sudo ./NVIDIA*.run
11.a) Answer to the affirmative for all questions.
11.b) Be sure to specifically say you DO WANT it to write a new xorg.conf
11.c) If you somehow answered incorrectly on the last question in the installer then:
c.I) sudo nvidia-xconfig #this will write a new or attempt repair of
an xorg.conf file for you.

12) sudo /etc/init.d/gdm start
12.a) You should see an Nvidia Logo, and then be put at your login screen,
you should also be able to enable desktop effects.

Optional But recommended:
13) To get the driver to update itself when a new kernel is installed from the update
manager be sure to follow the guide in this link:
http://ubuntuforums.org/showpost.php?p=5227704&postcount=1

Adamant
November 19th, 2008, 12:43 PM
if you're trying to watch a movie etc
in vlc to get the "flicker" off - go to prefs and hit video, and switch the output to X11. worked for me ..
i dunno about websites etc, but that works for vlc..