PDA

View Full Version : [ubuntu] gdmsetup exits with segmentation fault



thomasyen
October 3rd, 2008, 10:06 AM
Today while trying to make adjustments to my login theme using System -> Administration -> Login Window, the gdmsetup window opened for about two seconds and then crashed. I tried invoking it from the command line, but it also exited two seconds later with a segmentation fault. Never had this happen to me before. Any ideas on how to fix this?

Sycron
October 3rd, 2008, 10:39 AM
What version of ubuntu are you using ?

thomasyen
October 3rd, 2008, 11:16 AM
I use 8.04 Hardy.

Sycron
October 3rd, 2008, 11:17 AM
On my computer, and on the liveCD also gdmsetup just works. Can you reset the settings to default somehow ? Or could you tell us what you've changed ?

thomasyen
October 3rd, 2008, 11:22 AM
I'm not sure what I changed. Maybe you could tell me how to revert to default? (I tried reinstalling gdm - didn't work)

Sycron
October 3rd, 2008, 11:24 AM
sudo apt-get --purge remove gdm
sudo apt-get install gdm

thomasyen
October 3rd, 2008, 02:31 PM
After doing what you said and rebooting, I found that gdm behaved strangely - every word of the filenames and system responses (every single letter) had been replaced with small rectangles! I had no choice but to reinstall. So now there is no problem with my computer. But for future reference, purging then reinstalling gdm is probably not a good idea.

drshields
October 4th, 2008, 06:32 AM
I'm also getting the same problem.

System->Accessories->Login Window, it disappears after 1 second.

So I try to do it via terminal and get this:


$ sudo /usr/sbin/gdmsetup
Fontconfig error: "~/.fonts.conf", line 2: no element found
Segmentation fault

This just started today from what I can tell... One other thing I'm noticing that's weird, System->Preferences->Appearance, Click on the Customize button I'm not seeing any preview icons (except for a question mark indicating the icon is missing) for the Controls and Icons tabs. I'm not sure if it's related, but this wasn't happening prior either.

The only thing I've installed recently is Cairo dock and some fonts. I'm on 8.04...

thomasyen
October 11th, 2008, 04:47 AM
Now that you mention it, I also seem to have installed Cairo-dock prior to having this problem. Maybe you could file a bug?