View Full Version : [ubuntu] BUG: soft lockup - cpu #0 stuck for 11s [modprobe:1282]

October 1st, 2008, 09:38 PM
Whenever i start ubuntu (8.04) i get the following message:
BUG: soft lockup - cpu #0 stuck for 11s [modprobe:1282]

i have no idea what to do.
no matter how i install/attempt to run ubuntu the same thing happens.

this installation was installed through windows, but whenever i try to run the installation/live cd the same thing happens.

October 1st, 2008, 11:07 PM
i just tried 8.1 intrepid.
that doesnt work either.
but instead of actually giving me an error message, it just does nothing. it never gets past the boot splash screen. it just shows the splash, and freezes.

October 1st, 2008, 11:17 PM
Go back to trying the hardy cd, when you get to the main menu press F6 and remove splash and add
noapic to the end of the line and press enter and see what happens.

October 2nd, 2008, 12:50 AM
now it says:
PCI: BIOS BUG #81 [49435000] found
Loading, please wait...
BUG: soft lockup - CPU#1 stuck for 11s! [modprobe:1262]

October 2nd, 2008, 11:14 PM
come on, this cant be unsolvable.
also, i tried 64-bit last night.
same deal.

October 3rd, 2008, 01:35 AM
Try updating your bios if you are able to.

October 3rd, 2008, 02:30 PM
There are no BIOS updates available.
Acer doesn't support this model very well at all.

October 3rd, 2008, 03:45 PM
There are no BIOS updates available.
Acer doesn't support this model very well at all.

Which Acer model do you have? Also if you post your BIOS type (or motherboard type) someone might know more ways to help you.

October 3rd, 2008, 06:20 PM
acer aspire 5430
my system bios are pheonix bios version 1.3309 (this is stated within the bios)
when i start it up the first thing it says is pheonix bios 4.0 release 6.1
right after that it tells me the following: BIOS Revision BOWFIN BIOS BW-B16-16Feb2006-BR17213(rev8.050I.000)

October 4th, 2008, 12:43 AM
Are you trying to install the 64bit version or 32bit version of ubuntu?

October 4th, 2008, 05:02 PM
i would prefer to install the 32 bit version, but i was trying the 64 bit version to make sure it didnt work as well.
so yes, im trying to install the 32 bit version.

October 6th, 2008, 01:36 PM
im not sure if it makes a difference in the situation, but i tried installing a bunch of other distros of linux, none worked.
i tried fedora, knoppix, backtrack, mandrake, i even tried solaris.
however, there was one that worked, DSL.

October 7th, 2008, 03:19 PM
bump because id like to not have vista anymore..

October 7th, 2008, 11:06 PM
Try using some different boot options by themselves and in different combinations
Someone else had success with a similar problem by removing quiet and splash from the boot options.

October 10th, 2008, 01:26 AM
Same problem here with Ubuntu 8.04 on my Xen server. I tried removing quiet and splash, setting acpi=off, noacpi, etc. - none work.

The (temporary) solution for me was to change my CPUs to 1. This appears to be an issue with SMP. As soon as I bump the CPU count to 2 (or 4 as I'd like to use all 4 cores in my dual socket, dual core system), I start getting these lockups.

When I use a Debian Etch install on the same host, I have no problems with using all 4 CPUs. This appears to be unique to the Ubuntu kernel 2.6.24-19. Apparently 2.6.24-18 is un-afflicted.

Take a look at this board: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/245779

October 10th, 2008, 05:51 AM
Maybe you could try intrepid and see if the problem presists. You can either wait for a few more weeks till its release or you could download intrepid beta.

October 15th, 2008, 11:38 PM
as of right now 8.1 isnt helping.
i just downloaded it again and tried it.
not exactly the same prioblem, but similar.
this time im told the following:
BUG: soft lockup - CPU#0 stuck for 61s! [modprobe:5228]
BUG: soft lockup - CPU#1 stuck for 61s! [kstop0:5298]

October 16th, 2008, 01:01 AM
Have you tried what is mentioned in post #15 by JustinThomas, and change your cpu's to 1?

October 17th, 2008, 11:01 AM
On my notebook, HP 6720s CoreDuo, I have a similar problem: I get the "CPU stuck" message, yet it occurs only sometimes, ie. sometimes I can boot properly with no error and sometimes Ubu gets stuck and I have to hard-restart. WTF? :D

Ubuntu 8.04.1 fully up-to-date (previously only important + recommended, now also proposed - in both cases same problem - 2.6.24-19 and 2.6.24-21).

PS It didn't happen before at all or happened very, very rarely (not sure now).

October 20th, 2008, 04:11 PM
wel, i cant do it anywhere in my bios, but as soon as can ill try the bootline code and see if that works.
i cant lie, i have my doubts, but ill give it a shot.

October 20th, 2008, 08:40 PM
yeah, i tried the only discernable thing, NO_HZ=y
no luck, exact same results.
is there some way to tell ubuntu to only use one core when booting? maybe that would help?

i just want to clarify this a little better.
every post i find on this seems to be a description of how ubuntu would crash after a while of uptime. this is not the case for me. it doesnt boot, at all, ever.
the only thing i can do to change anything is edit the boot code.

October 23rd, 2008, 05:23 PM
Well, there's the option concurrency=shell in /etc/init.d/rc to enable 2core booting, but it's disabled by default - unless You somehow got it enabled, it won't help; however - worth a try...

October 25th, 2008, 08:37 PM
well, ive never had ubuntu installed on my laptop, so im going to go ahead and assume it's not enabeled.
but then could you explain why it says that both of my cores soft-lock when booting the 8.1 setup?

October 25th, 2008, 09:17 PM
It's really weird... :/
Additionally, on my laptop (6720s), I've gotten this error just a few times, though I've been booting into Ubuntu plenty of times every day...

November 6th, 2010, 01:09 PM
Hi Everyone
i had the same problem installing 10.04 on a A7N8XE motherboard getting the same error message but i downloaded 10.10 and installed it witout problems so this bug seems to be fixed (for me anyway) in 10.10

hope this helps

December 10th, 2010, 01:51 PM
BUG: soft lockup - cpu #0 stuck for 11s [modprobe:1282] (http://ubuntuforums.org/showthread.php?t=935396) Reply to Thread I have many these message ,And I can't boot into my ubuntu10.04