PDA

View Full Version : can you rip dvd's from a remote front end



mark467
September 30th, 2008, 10:38 PM
and if so how?

DemonBob
September 30th, 2008, 11:45 PM
Well...

Depends on the setup.

Setup 1:

Remote Frontend. If the Remote frontend mounts the media directory's from the backend. Then you could sit at that front end and rip to the video's directory.

Setup 2: (Might work)

Install Samba on the remote frontend, and share out the mountpoint for the dvd driver i,e /media/cdrom

Then mount the share on the pc you want to rip it to, and rip it that way...

mark467
September 30th, 2008, 11:55 PM
Well i tried step 1 before. i get the video info in the rip screen but then it just goes to nothing to do waiting screen

uopjohnson
October 1st, 2008, 12:11 AM
That happens when there is somethign wrong with the DVD. Either it is protected by somethign that linux can't crack or it is scratched somehow. Try an old dvd, or once you have made yourself to ensure that the process works.

mark467
October 1st, 2008, 12:40 AM
it is happening with all of them (all dvd's i try). I did change the setting under media settings location of dvd device from /dev/cdrom0 to /dev/scd0 then i changed it to /dev/dvd and same thing. before that it didnt find a dvd in the drive. it looks like its going to work then goes to nothing to do screen. i can watch movies fine from the backend on the front end (VIA NFS MAPPED FOLDER)

uopjohnson
October 1st, 2008, 06:09 AM
Mythdvd leaves a log file in /var/lib/mythdvd/temp/mtd.log
You can check that for more info. That is urually where you will find errors that directories aren't writable, which may be yoru problem.

mark467
October 1st, 2008, 09:58 PM
That seems to be it. It is a mounted nfs share that should be able to be written to though. I can copy stuff there from my windows box.


16:49:17: Using DVD source: /dev/scd0
16:49:17: Error: DVDISOCopyThread could not open output file: /var/lib/mythtv/videos/UNIT_S2D3_001of
16:49:19: job failed: job dvd 2 1 -1 0 -1 /var/lib/mythtv/videos/UNIT_S2D3

uopjohnson
October 2nd, 2008, 07:51 AM
Can you write to that directory on your frontend? Try:
[code]touch /var/libe/mythtv/videos/testfile[code]
Is that where your NFS share is mounted?

mark467
October 3rd, 2008, 11:44 PM
Hmm I guess not. I get this:

mark467@mythf804:~$ touch /var/lib/mythtv/videos/testfile
touch: cannot touch `/var/lib/mythtv/videos/testfile': Read-only file system


What is confusing is that i can copy an iso from my windows box to that share with no authentication

mark467
October 3rd, 2008, 11:46 PM
Is it something in the way i shared it? This is my line in /etc/fstab

192.168.1.25:/var/lib/mythtv/videos /var/lib/mythtv/videos nfs rsize=8192,wsize=8192,timeo=14,intr

uopjohnson
October 4th, 2008, 12:20 AM
It is probably a problem with the way it is mounted since you can write just fine from your windows box. Mounting listed in teh fstab is doine by the root user so sometimes you have to mess aroudna bit with the permissions to get it working.
try


192.168.1.25:/var/lib/mythtv/videos /var/lib/mythtv/videos nfs rsize=8192,wsize=8192,timeo=14,intr,gid=users,umas k=000

added ',gid=users,umask=000' to the options
You might also want to check the permissions on the mount point


ls -l /var/lib/mythtv/videos

mark467
October 4th, 2008, 07:17 PM
drwxrwxr-x 2 mythtv mythtv 4096 2008-10-03 22:08 videos

are the permissions on /var/lib/mythtv/videos

and i tried changing the mounting as suggested but didnt change outcome.

mark467
October 18th, 2008, 08:51 PM
anybody have any suggestions. I coppied dozens of iso's from my windows box without changing anything....

uopjohnson
October 18th, 2008, 09:56 PM
Sorry I lost track of this thread.
Try:

sudo touch /var/lib/mythtv/videos/testfile
To see if it is a permissions problem or a mount problem.

mark467
October 19th, 2008, 12:38 PM
mark467@mythf804:~$ touch /var/lib/mythtv/videos/testfile
touch: cannot touch `/var/lib/mythtv/videos/testfile': Read-only file system


What is confusing is that i can copy an iso from my windows box to that share with no authentication

uopjohnson
October 20th, 2008, 12:16 AM
You forgot the sudo, which will run it as root to ensure that it isn't a user permission error.

sudo touch /var/lib/mythtv/videos/testfile

mark467
October 23rd, 2008, 01:55 PM
ok with sudo i get

/var/lib/mythtv/videos/testfile': Permission denied

mark467
October 23rd, 2008, 02:02 PM
ok i did chmod 777 on the videos folder and it works now.
my question now is how ccould the windows machine write to it but mythbuntu can not?

uopjohnson
October 23rd, 2008, 06:18 PM
It is a local permission problem. Windows probably mounts all shares as read/write. Its weird becuase I thought the umask=000 would have set the permission on the folder to 777.

mark467
October 28th, 2008, 02:20 AM
I usedchmod 777 on the folder, should i remove the umask=000 from my mount data? it works now though thanks