View Full Version : [ubuntu] [SOLVED] ipod crisis

September 24th, 2008, 02:15 AM
I'm hoping this is just something silly I've missed but I have got Amarok working with the ipod and added new albums to my ipod but now when I have un-docked the ipod it searches through all the albums/artists etc with no problem but it will not play any songs - even the ones that were on it before. It just gives click and the timer doesn't move through the song but stays at the beginning!

Any ideas?

September 24th, 2008, 02:25 AM
what version iPod?

September 24th, 2008, 08:29 AM
Sorry I had to go off to bed, it was 2am here...

It is an 80GB ipod Classic

September 24th, 2008, 09:55 AM
I've realized I though I had downloaded albums onto my ipod since I have been using Linux but actually I have only uploaded them from the ipod to the (now fully) Ubuntu pc. Would i need to change the software on the ipod could this be why the tracks don't play (but if so why would I be able to search through all the albums etc)

A very puzzled & and stressed

September 24th, 2008, 02:33 PM

September 24th, 2008, 03:14 PM
I've noticed once on my vista pc, that i had an error which ordered me to format my ipod in order to use it on windows. so it might be what you said, but that's not completely sure...

already tried the reset?

switch lock on - lock off- push menu and play button until apple icon popups.

September 24th, 2008, 03:31 PM
I tried doing this reset, when you press the menu and play button (I assume you mean at the same time) the screen goes blank and no apple sign pops up when I let go the screen was just as it was before I held them down!

I went through the menu to the reset and it asked me if I was sure then asked me what language I wanted but after that it was the same albums on and still just giving a little click when I try to play them.

Just out of interest I've tried connection it to Ubuntu again and it shows all the files on there but won't play them through either Amarok or Rhythmbox- yesterday it was doing this without a problem.

clive littlewood
September 24th, 2008, 03:51 PM

Why are you trying to play music on your ipod through Amarok ?

Amarok should have the base library from which you transfer to your ipod.

You should be able to play your music in the library in Amarok.

Maybe i am confused !!! with your problem.


September 24th, 2008, 04:23 PM
This thread should fix your problems

The problem is the newer iPods use some technology that locks them to iTunes. Apple's way of hurting Linux users

September 24th, 2008, 05:29 PM
Thanks for the advice guys, Clive the music was in Amarok on my PC as well but I thought I'd try playing the ipod files through the pc to see if they worked. I have followed the advice above and also here: http://www.linuxjournal.com/article/9266 and used my windows laptop to download itunes and update the ipod to the new firmware. I also decided that as the tracks on the pc were behaving in a strange way (the music was clear but the singer sounded like they were in another room!) I would delete the whole library of mixed file types and redo it all with mp3's as these will play on the ipod as well as Ubuntu (shame about ogg it sounds like good quality) so as long as my first disk transfers and plays I should be fine, of course if not... will mark as fixed if it works...