PDA

View Full Version : [all variants] screen resolution problem after first log off



dorhelp
September 24th, 2008, 01:10 AM
I upgraded from LTS 6.06 to LTS 8.04. When you boot and do the original log in the screen resolution is fine, after log off it changes to 640 X 480 for the login screen and when you log in the screen resolution utility under preferences only allows 640 X 480. Now if you shutdown and reboot it goes back to normal for one Xsession but reverts to 640 X 480 resolution after that until you reboot. Any ideas on how to fix this? It worked just fine before the upgrade. I tried switching from ubuntu to xbuntu in hopes it might help but no luck it does the exact same thing.
Thanks
Linda

Sef
September 24th, 2008, 05:56 AM
1) What is your graphics card?

2) Did you have restricted drivers installed when you updated?

dorhelp
September 24th, 2008, 04:35 PM
It is a T2742 Emachine I bought in June 2004. It is just using the built in graphics from the mother board. It lists as Intel Extreme Graphics 3D 64 MB shared memory on the specs when I bought it.

If it is a problem with the driver or card why would it work for the first xsession but cease to work after you log off.

I'm thinking about seeing if I get a live CD and run it off that if it does the same thing. If that works I'll just do a clean install. It is just that I have some LOKI games on the machine that I'm not sure I will be able to get working again if I start over since the bug fixes etc aren't around anymore

redfireplace
October 24th, 2008, 09:49 PM
I'm having the exact same problem. Usually when I boot the computer, my screen resolution is 640x480. I restart X by pressing ctrl-alt-backspace, log in, and it goes to my desired resolution of 1280x960.
This doesn't happen every time. Sometimes when I boot the computer, it goes right to the correct resolution. In rare instances, I have the problem and restart X, but the resolution stays at 640x480. The only way to fix it is to reboot the computer.
I did a fresh install of 8.04.1 when it came first out and have had the problem since then.
I have a Dell Dimension 8300 with an Nvidia GeForce 7600 GT video card. I installed the proprietary Nvidia driver from Ubuntu's restricted driver manager. I am not using Compiz.
Is this a bug somewhere? Or is there a setting I can change to fix this? Any help is appreciated.