View Full Version : [ubuntu] Amarok Problems

September 23rd, 2008, 07:35 PM
I am having real problems with Amarok. It has recognised my ipod and the files already on it - which I though would be the bigger problem - however it won't let me rip my cds. It will recognise and play them but the option to copy the tracks is greyed out and there is no menu item to rip them. I ripped one with Rhythmbox music player and it added it into the database and yet when I open Amarok it can't find the album (they both use the same music folder on my external hard disk) and Rhythmbox will play the tracks on my ipod but not copy them from the hard drive to the ipod.

Any ideas anyone of how I can do the whole process with one prog (I hoped it would be Amarok)



September 23rd, 2008, 07:38 PM
what version iPod? What verision of Ubuntu/Amorok? What database did you set up for Amorok?

Have you tried exaile?

September 23rd, 2008, 07:50 PM
Sorry, it is an ipod Classic 80Gb, Ubuntu 8.04 up to date, Amarok (through the package manager) and SQ Lite.

I haven't tried exaile, I'll go and look for it in Synaptic now.

Hope that clarifies

September 23rd, 2008, 07:55 PM
I think it is because K3B embeds itself in amarok and it is the former that rips a CD rather than the latter. I think soundjuicer would be a better ripping option for ubuntu
sudo apt-get install sound-juicer

If Amarok does not spot new music check you have Scan Recursively and then Tools -> Rescan collection and look then

September 23rd, 2008, 08:06 PM
I have checked in Synaptic and I already have Sound Juicer installed although it is not appearing in my applications menu bar.

I have tried Exaile and it won't mount my ipod even with the correct plugin enabled

September 23rd, 2008, 09:40 PM
I have now got Sound Juicer working, the problem is that it is rippong in Ogg so I need to use yet another program to transfer this to mp3, maybe if I change to ripping in wav Amarok will read this?

September 24th, 2008, 01:43 AM
If you get the


package with synaptic you will be able to rip to mp3 with Sound Juicer.