PDA

View Full Version : [ubuntu] [SOLVED] It wont mount my partition



slughappy1
September 23rd, 2008, 06:56 PM
I made several partitions on my hdd. I first made and installed a partition for Vista. I then made one for /boot, another for the rest of OS. And then finally an extra one for file sharing. I encrypted the Ubuntu installation by using a lvm and encrypting that. So my hdd looks like this:

/dev/sda1 -> NTFS ( Vista )
/dev/sda2 -> ext3 ( /boot )
/dev/sda3 -> ext3, lvm encrypted installation ( I think it's ext3 at least )
/dev/sda4 -> fat32 ( mounted during installation as /windows )
/dev/sda
But when I go to Places it isn't there. There is only the Vista partition. When I
ls /dev/sda* it finds the other parition. But I want it to be up in the Places tab, or at least make it so that I don't have to always
sudo mount /dev/sda4 SomePlace What can I do to fix/change this?

hyper_ch
September 23rd, 2008, 06:57 PM
what's in your fstab?

slughappy1
September 23rd, 2008, 07:15 PM
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/mapper/lvm-root
UUID=e7fcfdaf-f8cc-4446-89aa-a18a6354db85 / ext3 relatime,errors=remount-ro 0 1
# /dev/sda2
UUID=3fe02bcd-1e04-4ec0-b52a-6f55e79df698 /boot ext3 relatime 0 2
# /dev/mapper/lvm-home
UUID=4d1b9a68-a8f0-43e3-84a2-3e6f331c2057 /home ext3 relatime 0 2
# /dev/sda4
UUID=3659-58F0 /windows vfat utf8,umask=007,gid=46 0 1
# /dev/mapper/lvm-swap
UUID=5e5e75e5-796c-4f5e-8012-0a5ecf9be834 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0

hyper_ch
September 23rd, 2008, 07:19 PM
so it is being mounted at /windows .... is that a problem?

slughappy1
September 23rd, 2008, 07:22 PM
*slaps forehead. Oops, I didn't realize that it would be mounted there.

hyper_ch
September 23rd, 2008, 07:22 PM
well, if you want to have it mounted somewhere else, create that directory and then change fstab accordingly.

slughappy1
September 23rd, 2008, 07:24 PM
If I were to change where it mounts it.

Would I just change the /windows to /What_ever_I_wanted?
Would changing the mount point pose any problems?

hyper_ch
September 23rd, 2008, 07:26 PM
Would I just change the /windows to /What_ever_I_wanted?
no

Would changing the mount point pose any problems
mights... some applications may look for certain files stored at the old mount point... like when you open OOo and then want to open a recent document that was on /winodws/yadda/yadda/some.odf

slughappy1
September 23rd, 2008, 07:30 PM
Since you say no, then what would I change it to?

hyper_ch
September 23rd, 2008, 07:51 PM
whatever you want... if you want to have it appear in the "Places" I think it will need to be mounted somewhere in /media.... e.g. /media/windows

slughappy1
September 23rd, 2008, 08:10 PM
Ok, thanks that worked. I changed /windows to /media/Shared ( after I created the dir Shared in /media ), and it worked. How about this one. Now how do I get it so it doesn't automatically appear on the Desktop?

hyper_ch
September 23rd, 2008, 08:20 PM
oh, you want to have it on the desktop?

I'd create a symlink



ln -s /media/Shared /home/USER/Desktop/Windows


replace USER with your username, then you should also be able to edit the symlink properties by right-clicking on it on the desktop and select another icon.

slughappy1
September 23rd, 2008, 08:24 PM
No, that's the problem. I do NOT want it on my desktop. But when I changed the mount point from /windows to /media/Shared. I restarted my computer, and an icon showed up on my desktop "40.0 GB Media". When I created the partition for Vista, it shows up in Places ( which the 40.0 GB Media does as well now ), but the Vista partition does NOT show up on the desktop. I want to make the new partition just like the Vista partition.

hyper_ch
September 23rd, 2008, 08:27 PM
oh, I didn't read the "doesn't" ;)

I don't use gnome but go to your desktop settings... very likely there is an option to not display additional harddisks/partitions on the desktop.

slughappy1
September 23rd, 2008, 09:28 PM
Ok, so I figured that part out thanks to here (http://www.daryl.mu/2008/03/30/howto-remove-desktop-mounted-volume-icons-in-ubuntu/). So you can either do one of two things.

1 - In the terminal type

gconftool-2 --type boolean --set /apps/nautilus/desktop/volumes_visible false

or

1 - Make sure Configuration Editor shows up in Applications -> System Tools -> Configuration Editor
2 - Open the Configuration Editor, and un-click the volumes_visible box in /apps/nautilus/desktop/