PDA

View Full Version : [ubuntu] [SOLVED] No grub folder in /boot



svanheulen
September 22nd, 2008, 04:32 PM
I was going to add Windows to my grub menu and I don't seem to have a grub folder in /boot. Where do I find menu.lst?

person@place:~$ ls -l /boot/
total 18877
-rw-r--r-- 1 root root 422667 2008-08-21 00:46 abi-2.6.24-19-generic
-rw-r--r-- 1 root root 80049 2008-08-21 00:46 config-2.6.24-19-generic
-rw-r--r-- 1 root root 7985925 2008-08-26 10:32 initrd.img-2.6.24-19-generic
-rw-r--r-- 1 root root 7985957 2008-08-21 19:27 initrd.img-2.6.24-19-generic.bak
-rw-r--r-- 1 root root 905170 2008-08-21 00:46 System.map-2.6.24-19-generic
-rw-r--r-- 1 root root 1921464 2008-08-21 00:46 vmlinuz-2.6.24-19-generic

svanheulen
September 22nd, 2008, 08:22 PM
No one? Grub is there when I boot up so it must be installed someplace, how do I find where?

caljohnsmith
September 22nd, 2008, 09:09 PM
How about posting the output of:

sudo fdisk -lu
sudo grub
grub> find /boot/grub/stage1
grub> find /grub/stage1
grub> quit
That should give us a good place to start. :)

svanheulen
September 22nd, 2008, 09:23 PM
I figured it out, my boot partition wasn't mounted. I thought it was because when I tried 'sudo mount /boot' it said 'mount: /dev/sda1 already mounted or /boot busy' but then I realized my boot partition isn't sda1 because it's on a nvraid. So once I got it mounted everything was where it should be.