View Full Version : [ubuntu] Gedit plugin problem

September 21st, 2008, 05:44 PM
Hi, I am using Ubuntu 8.04 and when I tried to install quickhighlightmode gedit plugin I met this:
1. If start gedit with "gedit", the plugin can be find in active plugin list and worked properly.
2. If start gedit with "sudo gedit", the plugin cannot be find in active plugin list.
Any suggestions?

September 22nd, 2008, 09:26 AM
You oughtn't to start graphical apps with “sudo”. Use “gksu” (or “kdesu” for KDE).
(See http://www.psychocats.net/ubuntu/graphicalsudo)

I don't know if this is related to your current problem or not.

September 22nd, 2008, 09:44 AM
How did you install the plugin? If you put it in ~/.gnome2/gedit/plugins then it is only installed for you, not any other root users, including the root user. If you want all your plugins to be used by root too then you can link the root plugins folder to yours.

sudo mkdir /root/.gnome2/gedit
sudo ln -s /home/yournmame/.gnome2/gedit/plugins /root/.gnome2/gedit/plugins

September 23rd, 2008, 04:11 AM
It works:) thanks, ad_267.

September 23rd, 2008, 04:46 AM
sudo ln -s /home/yournmame/.gnome2/gedit/plugins /root/.gnome2/gedit/plugins

Just a note:
When giving advice on the forums, it's best if you can keep to a minimum the stuff that the users have to change. Changing “yournmame” into the correct user name is just one more thing for them to type, and mess up. The following is better:

sudo ln -s ~/.gnome2/gedit/plugins /root/.gnome2/gedit/plugins

The tilde (“~”) automatically expands to that user's directory. “$HOME” does the same. If you only want the user name itself, you can use “$USER”.