PDA

View Full Version : [ubuntu] Can't Mount Harddrive



Joseph5000
September 21st, 2008, 05:24 AM
New hard drive, At first I could mount it, but now I can't. Error as follows.
$MFTMirr does not match $MFT (record)

wolfen69
September 21st, 2008, 05:34 AM
i'm afraid this will require windows to fix. MFT is Master File Table which is a windows thing. with an xp cd you can run "chkdsk /f" (no quotes) in recovery console.

Joseph5000
September 21st, 2008, 05:38 AM
You find me lost. How can it run at first, then after 10GB download it crashes, and then I can't restart it. Yes, I checked through XP, and that OP can see it, But why can't Ubuntu Mount it?
Are you saying that the evil XP has taken over in the middle of the process ad I can use this (external) Hard drive only with windows?

sayakb
September 21st, 2008, 05:41 AM
At a terminal:

sudo apt-get install ntfsprogs
Then run ntfsfix on the drive.

Joseph5000
September 21st, 2008, 05:46 AM
Here comes the bloody beginner. I run the command you wrote, but how do I run a ntsffix?

sayakb
September 21st, 2008, 05:49 AM
Just the same way you run the command! :)
Details of package ntfsprogs: http://packages.ubuntu.com/hardy/ntfsprogs

EDIT: w00t! 2800 up! :D