PDA

View Full Version : [ubuntu] [SOLVED] Touchpad doesn't work.



edivimo
September 20th, 2008, 08:44 PM
Hi, i'm a newbie... please be kind!
Well, i have a toshiba laptop (satellite pro) and installed on it "ubuntu 8.04.1 amd64 LTS". The installation of Ubuntu was made with a usb-mouse connecter and i prefer it over the touchpad, but in ubuntu i can't choose, because the touchpad does'nt work, with or without the usb mouse connected.

Reading about synaptics touchpad in http://tuxmobil.org/touchpad_driver.html , i used this commands with the respective output:


$cat /proc/bus/input/devices"

...
I: Bus=0011 Vendor=0002 Product=0007 Version=92b1
N: Name="SynPS/2 Synaptics TouchPad"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input8
U: Uniq=
H: Handlers=mouse1 event8
B: EV=b
B: KEY=6420 7000f 0 0 0 0
B: ABS=11000003

I: Bus=0003 Vendor=093a Product=2510 Version=0110
N: Name="PIXART USB OPTICAL MOUSE"
P: Phys=usb-0000:00:13.0-2/input0
S: Sysfs=/devices/pci0000:00/0000:00:13.0/usb2/2-2/2-2:1.0/input/input9
U: Uniq=
H: Handlers=mouse2 event9
B: EV=17
B: KEY=70000 0 0 0 0
B: REL=103
B: MSC=10
...

So, that means i have a synaptics touchpad, later this page says:

"For Kernels >= 2.6 also you need the psmouse driver loaded in order to correctly use a Synaptics Touchpad. Then dmesg shows e.g.:


Synaptics Touchpad, model: 1
Firmware: 5.9
Sensor: 37
new absolute packet format
Touchpad has extended capability bits
-> multifinger detection
-> palm detection
input: SynPS/2 Synaptics TouchPad on isa0060/serio1
"
And in my laptop appear this lines, the most similar to previous:


...

[ 49.026442] Synaptics Touchpad, model: 1, fw: 6.3, id: 0x9280b1, caps: 0xa04711/0xa04000

...

[ 49.104678] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input8

...

In "Systems\Preferences\Mouse" i have enabled the touchpad.

In "Systems\Preferences\Touchpad" doesn't work at the beginning but i edit the file "xorg.conf" adding this line:


Option "SHMConfig" "on"

To the [Section "Input devices" | Identifier "Synaptics touchpad"], that section was already there.
With this change "Systems\Preferences\Touchpad" load without problems and is enabled "Activate Touchpad"

So my xorg.conf looks:


# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "fglrx"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "es"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"
Option "SHMConfig" "on"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
Inputdevice "Synaptics Touchpad"
EndSection

Section "Module"
Load "glx"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection


So, how i fix the touchpad?

Thanks in advance...

starcannon
September 20th, 2008, 09:10 PM
I should be:

Option "SHMConfig" "true"Try that and I think your touchpad configurator will work.

If you need a good little touchpad configurator with gui:

sudo apt-get install gsynaptics
Almost forgot, you'll then find it's menu entry under: {System>Preferences>Touchpad}

GL and have fun.

edivimo
September 21st, 2008, 12:56 AM
I already do that, i have installed the last version of gsynaptics and it says the touchpad is enabled, but still don't work. I haven't any error messages, that's why i am confused :confused:

KrazyPenguin
September 21st, 2008, 03:38 PM
Same problem here:
I have a Toshiba Satellite, the pad use to work with a fresh install.
After using the Logitech wireless mouse , the pad doesn't work anymore. Disconnecting the mouse and rebooting doesn't help.

KrazyPenguin
September 21st, 2008, 03:43 PM
Hey , this is funny :lolflag:

It didn't take me long to find a solution to this problem, and it is sooooo simple.

step 1) google is your friend
step 2) toshiba satellite touchpad doesn't work
step 3) click on link http://forums.computers.toshiba-europe.com/forums/thread.jspa?threadID=14601
step 4) read
step 5) press "Fn" + "F9" keys together
step 6) USE YOUR TOUCHPAD

LOL
:guitar:

edivimo
September 21st, 2008, 03:56 PM
That works only in windows, is the first thing i tried.

KrazyPenguin
September 21st, 2008, 04:09 PM
That works only in windows, is the first thing i tried.

Not true! :shock:

I'm using Hardy on a Toshiba Satellite and that switch works for me.

Actually all the buttons work.

:)

edivimo
September 23rd, 2008, 12:31 AM
:confused: Well, now it works, the only thing i made different was to plug the usb mouse while ubuntu was loading... and Fn + F9 doesn't work for deactivate, that's why i say it works only in windows... well i don't know, i'll continue reading about the theme.

flipper9
May 11th, 2009, 01:03 PM
I'm having the same problem on my Asus Eee PC 1000h running Ubuntu 9.04. I've edited xorg.conf, edited HAL, tried the F9 trick, EEE PC Tray says it's enabled, the Mouse control panel says it's enabled (I toggled it), GSynaptics says it's enabled, but it does'nt work. It used to work. I have to plug in a mouse now to be able to use Gnome (yes; I've tried removing the USB mouse, but they used to work together). Any ideas? Stumped here...

mpadwal
March 17th, 2011, 07:01 PM
Hey,,
I AM USING EMACHINE NET BOOK eM250.
I have installed ubuntu 10.10. Before today it was working fine.
But after shutdown when i have restarted. The touch pad is not working or its locked. I have tried all function key shortkeys but its not working. Please help me...:D

Oddvar
June 15th, 2011, 03:37 PM
Hey,,
I AM USING EMACHINE NET BOOK eM250.
I have installed ubuntu 10.10. Before today it was working fine.
But after shutdown when i have restarted. The touch pad is not working or its locked. I have tried all function key shortkeys but its not working. Please help me...:D

I have eMachines e527. For me the solution was
Fn+F7