PDA

View Full Version : [ubuntu] Stylistic LT P600 finally the Xorg and The touchscreen work



davideschiavon
September 20th, 2008, 06:55 PM
Hi Everybody,

After a WE I've finally find the right configuration for my Stylistic.

Today I'm Using Ubuntu 7.10 /works great!!!!

#####First####################################
root@style:~# dmesg | grep ttyS
[ 21.719956] serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
[ 21.721245] serial8250: ttyS3 at I/O 0x2e8 (irq = 3) is a 16550A
[ 21.722506] 00:08: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
[ 21.723467] 00:0c: ttyS1 at I/O 0xfd68 (irq = 5) is a 16550A
######Second###################################

Tips: If you have changed the serial port in the bios and you want to know wich one is the serial try:

cat /dev/ttyX

touch the screen and see if some ascii caractes appear on the screen.
######Third###################################
Once you know the state of your ports precede with the configuration:

setserial /bin/setserial /dev/ttySxxx autoconfig

setserial /dev/ttyS1 uart 16450 port 0xfd68 irq 5 low_latency baud_base 115200 spd_normal skip_test

####Fourth######################################
################################################## ####
Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Touchscreen"
InputDevice "Configured Mouse"

EndSection

Section "Files"
RgbPath "/etc/X11/rgb"
ModulePath "/usr/lib/xorg/modules"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "extmod"
Load "dbe"
Load "record"
Load "GLcore"
Load "dri"
Load "xtrap"
Load "glx"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection


Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
DisplaySize 211 158
HorizSync 28-40
VertRefresh 43-60
Option "DPMS"
EndSection

Section "Device"
Identifier "Card0"
Driver "ati"
VendorName "ATI Technologies Inc"
BoardName "Rage Mobility P/M"
BusID "PCI:0:20:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"

SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "InputDevice"
Identifier "Touchscreen"
Driver "fpit"
Option "Device" "/dev/ttyS1"
Option "BaudRate" "9600"
Option "Passive"
Option "CorePointer"
# Option "Rotate" "CW" <= works, but screen does not rotate via xrandr
Option "MaximumXPosition" "4070"
Option "MaximumYPosition" "4020"
Option "MinimumXPosition" "0"
Option "MinimumYPosition" "0"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "SendCoreEvents" "true"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection
################################################## ###############

I'm available for suggestions

cssetti
September 17th, 2009, 01:59 PM
THANK YOU!!!

This solved my battle with the great Stylistic LT P-600! it Appears that ttyS1 is the default serial. If you are having trouble (like me) go check the BIOS settings for serial configuration, this was changed from auto to serial 3 (or 4) with irq 8 i believe

Here is my Xorg.conf which works with xubuntu 9.04 jaunty jackalope

===================================


# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Touchscreen"
InputDevice "Configured Mouse"
EndSection

Section "Files"
RgbPath "/etc/X11/rgb"
ModulePath "/usr/lib/xorg/modules"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "extmod"
Load "dbe"
Load "record"
Load "GLcore"
Load "dri"
Load "xtrap"
Load "glx"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection


Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
DisplaySize 211 158
HorizSync 28-40
VertRefresh 43-60
Option "DPMS"
EndSection

Section "Device"
Identifier "Card0"
Driver "ati"
VendorName "ATI Technologies Inc"
BoardName "Rage Mobility P/M"
BusID "PCI:0:20:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"

SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "InputDevice"
Identifier "Touchscreen"
Driver "fpit"
Option "Device" "/dev/ttyS1"
Option "BaudRate" "9600"
Option "Passive"
Option "CorePointer"
Option "SendCoreEvents" "true"
#Option "Rotate" "CW" <= works, but screen does not rotate via xrandr
Option "MaximumXPosition" "4070"
Option "MaximumYPosition" "4020"
Option "MinimumXPosition" "0"
Option "MinimumYPosition" "0"
Option "TrackRandR" "true"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "SendCoreEvents" "true"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "emulate3buttons" "true"
EndSection

mrtpla62
May 5th, 2010, 02:45 PM
please my lt p600 don't go on my 9.04
is your ubuntu installation basic or you have
install other packages and how you configure setserial
thanks