PDA

View Full Version : [ubuntu] Having to disable desktop effects to play games?



mogsmar5
September 20th, 2008, 06:43 PM
Since upgrading to Hardy I've noticed that games flash a lot. The solution I've found so far is to disable desktop effects or use a program to switch from Compiz to Metacity. However, I don't remember this problem in Gutsy. Is there a way round this, as sometimes I have to disable effects just to use a media centre. I'm using an ATI Radeon 2400 graphics card, if it helps.

Thanks

flowevd
September 20th, 2008, 10:01 PM
i remember that running games fullscreen with compiz in gutsy, hardy, Arch, whatever, resulted in faintly-transparent fullscreen display followed inevitably by a crash. I guess it must be a compiz problem. the only fix i found was to invoke compiz with fusion-icon (in Sessions) and switch manually - although it sounds like that's what you're doing anyway.
i'd be interested if there were a workaround...