PDA

View Full Version : [SOLVED] Wacom causes reset of x-session



Jimtuv
September 18th, 2008, 06:15 PM
At first I thought this problem came from the terminal. What happens is that when I open a terminal and hit backspace my x-session is reset and I end up on the login screen. Come to find out the solution to that was to comment out the lines in my xorg.conf that contain the Wacom tablet. With those commented out I no longer have any problems with resets. However I need the Wacom to work.

What did I do wrong? Its a Wacom sapphire CTE-430 and here is my xorg.conf file.


# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Option "AddARGBGLXVisuals" "True"
Defaultdepth 24
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

#Section "InputDevice"
# Driver "wacom"
# Identifier "stylus"
# Option "Device" "/dev/input/wacom"
# Option "Type" "stylus"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
# Option "USB" "on"
#EndSection

#Section "InputDevice"
# Driver "wacom"
# Identifier "eraser"
# Option "Device" "/dev/input/wacom"
# Option "Type" "eraser"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
# Option "USB" "on"
#EndSection

#Section "InputDevice"
# Driver "wacom"
# Identifier "cursor"
# Option "Device" "/dev/input/wacom"
# Option "Type" "cursor"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
# Option "USB" "on"
#EndSection

#Section "InputDevice"
# Driver "wacom"
# Identifier "pad"
# Option "Device" "/dev/input/wacom"
# Option "Type" "pad"
# Option "USB" "on"
#EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
Inputdevice "Generic Keyboard"
Inputdevice "Configured Mouse"

# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
# InputDevice "pad"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Jimtuv
September 22nd, 2008, 01:19 AM
Still looking how to get the Wacom working without messing up my xorg.conf and having resets. Please if you have any information to help. I would greatly appreciate it.

jonspringall
September 29th, 2008, 08:56 AM
I have exactly the same problem, together with X reseting randomly.
I also looked elsewhere for the source before discovering that disabling my graphics tablet suddenly made my computer stable again.
I would love to be able to use my Bamboo One again - but with it enabled Ubuntu feels almost as unreliable as Windows 95!
I'm running Hardy Heron 8.04 on a Dell Inspiron 1525n, and installed the drivers using the instructions at: http://ubuntuforums.org/showthread.php?t=765915. I have since tried reinstalling using linuxwacom-0.8.1-4 (the current development version) with no improvement.

Here's my xorg.conf file:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

#Section "InputDevice"
# Driver "wacom"
# Identifier "stylus"
# Option "Device" "/dev/input/wacom"
# Option "Type" "stylus"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
# Option "USB" "on"
#EndSection

#Section "InputDevice"
# Driver "wacom"
# Identifier "eraser"
# Option "Device" "/dev/input/wacom"
# Option "Type" "eraser"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
# Option "USB" "on"
#EndSection

#Section "InputDevice"
# Driver "wacom"
# Identifier "cursor"
# Option "Device" "/dev/input/wacom"
# Option "Type" "cursor"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
# Option "USB" "on"
#EndSection

#Section "InputDevice"
# Driver "wacom"
# Identifier "pad"
# Option "Device" "/dev/input/wacom"
# Option "Type" "pad"
# Option "USB" "on"
#EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"
EndSection

Section "Device"
Identifier "Configured Video Device"
Option "UseFBDev" "true"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
SubSection "Display"
Depth 24
Virtual 3200 1880
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
# InputDevice "pad"
InputDevice "Synaptics Touchpad"
EndSection

Does anyone else have this problem? If you are experiencing apparent random crashes, especially while using the terminal - try disabling your Wacom tablet and see if your problem is solved.

I would be very grateful if anyone could advise us on how we can get our graphics tablets working reliably.

Jon

Jimtuv
October 4th, 2008, 06:47 AM
Sorry your having trouble too. But it is nice to know I am not the only one stuck on this. I am still trying to figure out what is the problem with this.

caffeine13
January 25th, 2009, 09:42 PM
I temporarily fixed the problem by changing to a different xterm program, but then found the problem popping up in some of my text editors as well. :(

----------

Okay, I think I might have fixed my particular problem by commenting out the "pad" wacom device in the xorg.conf file. Try it and see if it works for you too.

...

#Section "InputDevice"
# Driver "wacom"
# Identifier "pad"
# Option "Device" "/dev/input/wacom"
# Option "Type" "pad"
# Option "USB" "on"
#EndSection

...

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
InputDevice "stylus" "SendCoreEvents"
Inputdevice "touch" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
#InputDevice "pad"
Inputdevice "Synaptics Touchpad"
EndSection

Jimtuv
November 12th, 2009, 04:53 PM
A solution!!!! upgrade to Karmic 9.10 it solved everything. My wacom is working perfect now.