PDA

View Full Version : [gnome] Gnome 'forgets' compose key position



metafractal
September 18th, 2008, 12:19 AM
Hello,
I am having a strange problem with Gnome. I am able to set up a compose key by in Gnome under Ubuntu 8.04 by going into settings -> preferences -> keyboard -> layout options. The compose key then works until I reboot, after which ubuntu seems to 'forget' the setting and typing with the key produces no result. The funny thing is, when I go back into the layout options after a reboot, the left win key for the compose settings is still checked, and it will start working again if I un-check and re-check it but not otherwise.

Any ideas? It's annoying having to re-set it every time.

P.S. I've tried it with other keys than the left-win key and it still does the same.

ffahog
January 10th, 2009, 08:26 PM
Bump. I'm having the same issueŚcan anyone help?

mr_guy99493
October 16th, 2009, 02:58 PM
Same problem for me too.
Im going to try adding an xmodmap definition of the multi_key instead of doing it through the gui. Might work, havent tried yet.

sethtriggs
October 21st, 2009, 04:08 PM
Same problem for me too.
Im going to try adding an xmodmap definition of the multi_key instead of doing it through the gui. Might work, havent tried yet.

How do you do that, as I am having the same problem. What xmodmap definition would you use to ensure that the Compose key stays in place and where do you enter it?

-Seth

foresto
October 22nd, 2009, 08:15 PM
XFCE doesn't offer a GUI for this, so I change it by editing /etc/default/console-setup to contain this line:
XKBOPTIONS="compose:ralt"
(and then restart X)

To discover which keys you can use other than Right Alt, run:
grep compose: /usr/share/X11/xkb/rules/xorg.lst

More info:
https://help.ubuntu.com/community/ComposeKey