View Full Version : [ubuntu] [SOLVED] Booting from USB help

September 15th, 2008, 10:06 AM
Hey, Just need some booting from USB help,

I have BT3F.ISO, I placed it onto my USB, I then booted from USB device, I get an error saying " Missing operating system " Does this mean I can't boot from the USB with this .ISO? Does it only work if i burn the .ISO to a CD first?


northern lights
September 15th, 2008, 10:38 AM
It is the .iso's content, that needs be put on the flashdrive.

unetbootin (http://lubi.sourceforge.net/unetbootin.html) will be of help.

September 15th, 2008, 10:52 AM
Will this make my USB unusuasable for other things?

northern lights
September 15th, 2008, 12:00 PM

September 16th, 2008, 01:05 PM
I directed this program to the backtrack.iso then it just said to boot from USB which i did and it still didn't work.

northern lights
September 16th, 2008, 01:24 PM
I directed this program to the backtrack.iso then it just said to boot from USB which i did and it still didn't work.

Exactly how did you "direct" it?

Mkey. Let's do this step-by-step.

You downloaded unetbootin-linux-281, right?

This is a bin file, so I assume you made it executable.

The packages 'mtools' and 'p7zip-full' are required for the USB setup to work. The application should tell you, actually. In case you don't have these installed, run
sudo apt-get update && sudo apt-get install p7zip-full mtools

Connect your flashdrive and execute unetbootin. You could select the .iso, but in fact BackTrack3 can be selected directly from the menu. So tick "Distribution" radio button and select Backtrack3. Select "Type: USB Drive" and pick the one in question from the "Drive:" drop-down menu. Click OK.

Let it do its magic.

September 16th, 2008, 01:44 PM
Have a look at this (http://icebuntu.6.forumer.com/viewtopic.php?t=24) it'll walk you through how to install to a USB device device. You will need to edit certain parts to set up your specific config because this was done for IceBuntu (https://wiki.ubuntu.com/DerivativeTeam/Derivatives/IceBuntu).

Might be an idea to give IceBuntu a go as it's a low drain version of Ubuntu.

Hope it helps.

September 17th, 2008, 02:12 AM
I did that northen lights but it said " boot error ", Do i need a special USB .ISO ?

September 17th, 2008, 02:27 AM
Wait i was doing it wrong :P. I was pointing to the .ISO not slecting the version :P, but now on my USB, there are files it wont let me delete !

September 17th, 2008, 03:19 AM
I just went through this process and found both an easy way and a hard way. By the way, searching the BT forums will provide you with many answers and a new respect for the os.

If youre using windows, extract the files from the .iso to your flash drive. Open the boot folder and double click bootinst.bat. Follow the command line directives and that should be it.

Thats the quick way. It doesnt set up other partions for you which could come in handy if you want to save changes. I'll look for the link to the more lengthy set up process. Hope this helps!

September 17th, 2008, 03:31 AM
I know how to do it theres just 4 Files on m y USB now they it wont let me delete!

September 17th, 2008, 07:20 AM
Guys I cant even use my USB now, Please help!

September 18th, 2008, 03:11 AM
Its not one of those sticks with a little locking switch on it, is it? Ive been troubled by those simple security devices before...

September 18th, 2008, 10:36 AM
no.. Anyone else? I cant use my USB!

September 18th, 2008, 10:43 AM
Check the file permissions on the files you can't delete:

Navigate in a terminal to your usb drive and post the output of the following (after the - is a lower case L as in "list"):

ls -l

September 18th, 2008, 12:16 PM
I dont really understand that but i tried deleteing the files in the USB and it said the file system is read only, or along those lines

September 18th, 2008, 12:20 PM
open a terminal (Applications - Accessories - Terminal)

then type in
ls -l and post the info back here

September 18th, 2008, 12:23 PM
assasin@Invisible-Assasin:~$ ls -l
total 3111256
-rw-r--r-- 1 assasin assasin 3182682112 2008-08-06 07:30 brasero.iso
drwxr-xr-x 9 assasin assasin 4096 2008-09-16 07:22 Desktop
drwxr-xr-x 3 assasin assasin 4096 2008-06-24 18:17 Documents
lrwxrwxrwx 1 assasin assasin 26 2008-06-23 20:43 Examples -> /usr/share/example-content
drwxr-xr-x 11 assasin assasin 4096 2008-06-28 12:13 kiba-dock
-rw-r--r-- 1 assasin assasin 87890 2006-10-11 07:23 kiba-dock-0.1.tar.bz2
drwxr-xr-x 2 assasin assasin 4096 2008-08-21 14:23 lock
drwxr-xr-x 2 assasin assasin 4096 2008-06-23 20:56 Music
drwxr-xr-x 2 assasin assasin 4096 2008-08-04 16:11 Pictures
drwxr-xr-x 2 assasin assasin 4096 2008-07-22 17:46 Public
drwxr-xr-x 2 assasin assasin 4096 2008-06-23 20:56 Templates
drwxr-xr-x 2 assasin assasin 4096 2008-06-23 20:56 Videos

September 18th, 2008, 12:26 PM
ok, that shows us how things should look so you now, we need to change to where the usb is mounted. Still in the terminal, type in
sudo fdisk -l and post the output here

September 18th, 2008, 12:31 PM
Device Boot Start End Blocks Id System
/dev/sda1 182 3529 26892810 83 Linux
/dev/sda2 * 3530 4676 9213277+ 7 HPFS/NTFS
/dev/sda3 4677 4864 1510110 5 Extended
/dev/sda5 4677 4864 1510078+ 82 Linux swap / Solaris

Disk /dev/sdb: 4009 MB, 4009754624 bytes
145 heads, 48 sectors/track, 1125 cylinders
Units = cylinders of 6960 * 512 = 3563520 bytes
Disk identifier: 0x419ade4f

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 1126 3915752 c W95 FAT32 (LBA)

When i tried to delete the files it deleted two of them but two of them didint delete.

September 18th, 2008, 12:34 PM
ok, so the tumbdrive is mounted, where do you have it mounted at? You need to go to that directory in the terminal and then do the ls -l

September 18th, 2008, 12:52 PM
assasin@Invisible-Assasin:~$ ls -l /media/disk
ls: cannot access /media/disk/}.6: Input/output error
ls: cannot access /media/disk/┬EIt
fB.f9: Input/output error
ls: cannot access /media/disk/ └t ┤╗.: I┼⎻┤├/⎺┤├⎻┤├ ␊⎼⎼⎺⎼
├⎺├▒┌ 3830628
␍????????? ? ? ? ? ? ¼ └├?┤?╗.?
␍????????? ? ? ? ? ? ?.ë6á
␍????????? ? ? ? ? ? ë┬EI├?B.9?
-⎼┬│------ 1 ▒⎽⎽▒⎽␋┼ ⎼⎺⎺├ 2305195040 2031-01-05 15:46 ┐≡+╣?.½0
-⎼┬│------ 1 ▒⎽⎽▒⎽␋┼ ⎼⎺⎺├ 1617362456 1981-01-08 17:01 ?(║?²M.┴¡
␍⎼┬│------ 7 ▒⎽⎽▒⎽␋┼ ⎼⎺⎺├ 4096 2008-09-16 22:58 ??⎽≤⎽┌␋┼.UX
-⎼┬│------ 1 ▒⎽⎽▒⎽␋┼ ⎼⎺⎺├ 0 1980-01-01 01:00 *?▓>▄U ┴

September 18th, 2008, 12:55 PM
huh? what is that?

maybe we can do this another way, do you know if you have gparted installed? Would be under System - Admin - Partition Editor if you do

September 18th, 2008, 12:58 PM
Yes i do

September 18th, 2008, 01:06 PM
ok, open that up, select the thumbdrive from the drop down window in the upper right and then you should have an option to format from the actions menu I believe, just make sure you select fat16 or fat32 if you plan on using the drive in windows

do you have anything on there you want to save? if yes, don't do this

September 18th, 2008, 01:11 PM
How do i find the thumb drive?

September 18th, 2008, 01:12 PM
Wait i found it, I just cant find were to format

September 18th, 2008, 01:14 PM
do you see a box that says somelike like /dev/sda1 ? click that down arrow and see if it has /media/disk or something similiar

September 18th, 2008, 01:16 PM
Yeah im on that now, but i cant find were to format.

September 18th, 2008, 01:17 PM
ok, in your tool bar at the top, go to Partition - Format to Fat32

September 18th, 2008, 01:23 PM
Look at this http://img155.imageshack.us/img155/6343/screenshotdevsdbgpartedgz5.png (http://imageshack.us)

September 18th, 2008, 01:29 PM
ok, the drive is mounted, thats why you can't format it. Unmount the drive and then you should be able to format it

September 18th, 2008, 01:32 PM
IT WORKS! thanks so much! you saved me like $30, Im giving you so many thanks!

September 18th, 2008, 01:37 PM
~L~ glad it works and just a single thanks is enough :D

September 19th, 2008, 01:38 AM
~L~ glad it works and just a single thanks is enough :D

To late!