View Full Version : [ubuntu] can not switch the workspace

September 15th, 2008, 09:04 AM

usually, the following are useful to switch

* In the Workspace Switcher applet in the bottom panel, click on the workspace where you want to work.
* Move the mouse over the Workspace Switcher applet in the bottom panel, and scroll the mouse wheel.
* Press Ctrl+Alt+right arrow to switch to the workspace on the right of the current workspace.
* Press Ctrl+Alt+left arrow to switch to the workspace on the left of the current workspace.

but, now do not know why, I set 8 workpalce, can not use the above method to switch?

Only way is to use windows ket+e, and then click, any idea?

September 20th, 2008, 08:30 PM

I am having the same problem since an update a few weeks ago.

I have Hardy + Backports installed.

The problem only manifests itself when using compiz. I can switch desktops usind a compiz switcher which i have set up to invoke by an activecorner, same as Win+E. However, i cannot switch neither with my normal keystrokes nor with a Gnome Workspace switcher, nor by scrolling on the desktop as i could before.

When running a desktop without 3D effects everything works normally.

Interestingly, this must be a settings/user preferences problem, since when i created a new test user, these things worked properly there.

September 24th, 2008, 04:24 PM
yes you are right, may be the conflict with compzi.

February 2nd, 2010, 06:18 PM
Had a similar problem, turned out I disable compiz "Desktop Wall".