PDA

View Full Version : [ubuntu] How to make flash auto load



Draw2much
September 15th, 2008, 02:37 AM
Hello there! I've done searches for this and I can't seem to find an answer.

I currently use Firefox 3 and have flash installed. My problem is that flash will not run automatically. I have to click an ugly gray "start" button where ever there is flash. This gets very annoying in some websites where every page has a lot of flash in it.

How do I make flash load automatically in my browser?

aloshbennett
September 15th, 2008, 04:39 AM
Do you have flash blocker or similar plugin installed?

Draw2much
September 15th, 2008, 06:04 AM
I have Adblock Plus and Firestarter installed. As far as I know that's it. I'm pretty sure neither of them are the problem. I was thinking there must be a setting some where (maybe in a config file?) that's making it require a manual start. I just don't know where to look.

FuturePilot
September 15th, 2008, 06:26 AM
You most likely have gnash or swfdec installed. Try to remove them if they are installed. You can remove them from the command line if you like

sudo apt-get remove --purge mozilla-plugin-gnash swfdec-mozilla
Then install the Adobe Flash Player

sudo apt-get install flashplugin-nonfree

Draw2much
September 15th, 2008, 09:43 AM
Thank you! I actually already had nonfree flash installed, which is why I was so confused nothing was working right. I didn't have gnash but I did have swfdec and I guess it was interfering with nonfree-flash.

Once again, thanks! This solved my problem perfectly!

:KS:KS:KS:KS:KS

rbp
June 4th, 2010, 04:57 AM
thanks! Was facing the same problem (almost 2 years later) and that fixed it.