PDA

View Full Version : [ubuntu] Bsnl Broadband connection in UBUNTU (coding needed)



gopee1990
September 14th, 2008, 05:18 AM
Im a new user to ubuntu !!

I dont know how to connect to internet using linux terminal !
somebody said that i have to get coding for network connection !!

can you provid me coding for my specifications :
specifications in windows for bsnl broadband are:

Device Name :WAN miniport
Device Type :PPPoE
Server Type :PPP
Transports :TCP/IP
Authentication :MD5 CHAP
PPP multilink framing :off
server ip :xx.xx.xxx.x
client ip :xx.xx.xxx.xx
Address type :Manually configured
ip address :xxx.xxx.x.x
subnet mask :255.255.255.0
Default Gateway :192.168.1.1
Help me soon !!

:guitar:

Madman6510
September 14th, 2008, 05:22 AM
So, what are you trying to do?

tuxerman
September 14th, 2008, 05:23 AM
open up a terminal.
Type sudo pppoeconf, entering your password when asked.
Follow the instructions. When unsure, the default options are fine.
You can either start it manually each time by entering pon dsl-provider at the terminal each time or have it set to connect automatically at boot time.

I had written a page on this in my blog.. you can visit this if you want more infohttp://anotherbloggerbloke.blogspot.com/2008/07/broadband-in-ubuntu.html

Good luck :)

PS: Oh, and tell the person who told you that coding is required, that a single, simple command entered in the terminal is not something I would call "coding"

gopee1990
September 15th, 2008, 08:19 AM
thank you guys i will try the one and reply u again !!!
:popcorn:

mailtwogopal
September 15th, 2008, 09:04 AM
Hi gopee,

Surely it will work. no doubts. I had same instruction from this forum and i went by defaults. It really went fine.

gopee1990
September 17th, 2008, 03:30 PM
Thank you guys it really worked for me !! now i m a part of open source operating system linux ubuntu !!

:popcorn:

gopee1990
October 12th, 2008, 09:13 AM
hey guys ,
can you tell me how can i connect with the same configuration as above with :

fedora 9 and
open suse ????

please help me out !
:lolflag:

urgu
June 6th, 2009, 07:21 AM
My problem was that despite typing in all that code, what was supposed to happen didn't. Like, the IP address and stuff was supposed to appear, but it didn't. So, i configured my modem to automatically connect when switched on. No need to trigger the connection, just switch the modem on. This worked for me.

raj_guard
June 15th, 2009, 08:34 PM
Hi,

I use BSNL Broadband using the modem SmartAX MT882 Huawei.

I tried to configure using the procedure outlined in the blogpost in one of the posts/ But the result was not desired. The message read

"Sorry, I scanned 1 interface, but the Access Concentrator of your provider did not respond. Please check your network and modem cables. Another reason for the scan failure may also be another running pppoe process which controls the modem."

I guess it scanned 2 interfaces, eth0 and pan0.

Now how do i proceed, please help.

vijaybilgoji
July 26th, 2009, 07:01 AM
Bsnl broadband settings for ubuntu 8.04-

1.Type 192.168.1.1 in your browser u will get the router page open.
Type username-admin and password-admin to open this page.
2.In WAN Settings Select- PPP
3.Type u r username and password given to u by Bsnl.
4.Select- Always on.
5.Select-Apply
Router will save u r settings and reboot.

Now select the option DHCP just below WAN Settings

6.IN DHCP-- Enable the DHCP Server and click Apply
Router will save u r settings and reboot at this stage.

Close the router page.

7.Now go to the Top pannel of your desktop in that
i)click Network connection (At the right corner of ur pannel)
ii)Mannual configuration
iii)Select your wired connetion
iv)Click on properties
v)Select Automatic Configuration(DHCP)& Click on OK

Run your browser and enjoy the virus free browsing through ubuntu.

ashwinhgtx
November 12th, 2009, 09:15 PM
Bsnl broadband settings for ubuntu 8.04-

1.Type 192.168.1.1 in your browser u will get the router page open.
Type username-admin and password-admin to open this page.
2.In WAN Settings Select- PPP
3.Type u r username and password given to u by Bsnl.
4.Select- Always on.
5.Select-Apply
Router will save u r settings and reboot.

Now select the option DHCP just below WAN Settings

6.IN DHCP-- Enable the DHCP Server and click Apply
Router will save u r settings and reboot at this stage.

Close the router page.

7.Now go to the Top pannel of your desktop in that
i)click Network connection (At the right corner of ur pannel)
ii)Mannual configuration
iii)Select your wired connetion
iv)Click on properties
v)Select Automatic Configuration(DHCP)& Click on OK

Run your browser and enjoy the virus free browsing through ubuntu.

This doesn't work if the modem is in bridging mode.

GIRI MURALI
May 16th, 2010, 07:43 AM
i think some feels difficulty in connecting bsnl broadband in Ubuntu is because they need a dialer software.
This link will help you
http://www.beubuntu.co.cc/2010/03/connect-bsnl-broadband-in-ubuntu-hai.html