View Full Version : [ubuntu] Touchpad accuracy/sensitivity issues

September 12th, 2008, 06:22 PM
Hello all,

I have been fighting w/ my touchpad since I installed Ubuntu 8.04 x64.

I wish it would just work like it does in Vista or XP, but as long as I can configure it properly, I will be happy as a clam.

My biggest beef, when trying to make small precise movements, it get's really jumpy. I have tried messing with the touch sensitivity of the touch pad (how sensitive it is the pressure you apply), and the normal sensitivity option, as well as the acceleration...to no avail.

Another problem I have that is probably related, is that sometimes the touchpad doesn't respond to my 'touch'...is it giving me the silent treatment? :)

I am running a Dell Vostro, if anyone with a similar setup could send me your xorg.conf (I think that's where they reside) settings or provide any suggestions, I will be most grateful.


Tyler H
September 12th, 2008, 06:25 PM
What model of the Vostro. I'm running the 1000 series with 8.04 and everything works flawless.

September 12th, 2008, 08:44 PM
I've got the Vostro 1500...I think the only difference b/t mine and yours is yours has the AMD chipset as opposed to the Intel.

Would you mind posting the contents of your xorg.conf relating to pointing devices?

September 12th, 2008, 08:54 PM
sudo gedit /etc/X11/xorg.conf


Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
Option "SHMConfig" "true"


InputDevice "Synaptics Touchpad"

September 12th, 2008, 08:59 PM
If your touchpad is listed in xorg.conf as a Synaptics driver, then there is a GUI app that you can adjust you touchpad with called GSynaptics and it is in the repos. You can install with:

sudo apt-get install gsynaptics

September 18th, 2008, 06:34 PM

The touchpad on two of my machines are just WAY too sensitive, sending the cursor off into another portion of a document while I am typing if I happen to even brush the touchpad with my thumb.

I struggled with this for over 6 months with Fedora 8. In Fedora 8 there is no touchpad section in xorg.conf. I tried adding a touchpad section into xorg.conf on Fedora 8, and it was ignored. I never did find a solution in Fedora 8.

I am now running Kubuntu 8.04, and this worked just fine on both my daughter's Vostro 1700, and my Vostro 1710. On both machines, all I had to do was add the shmconfig option (everything else was already there), and install gsynaptics (there appears to be no KDE equivalent to the Gnome app). As we both run KDE, I added gsynaptics to the menu structure as well.

So, I can confirm that this solution works, and this terribly annoying oversensitive touchpad is now much more dormant.


September 28th, 2008, 10:25 PM
I installed gsynaptics as suggested, adjusted the sensitivity and disabled clicks, and it worked great. Except that at some point in my session, all of these settings randomly revert to the way they were before and I have ultra-sensitive mouse clicks again that make it almost impossible to type.

August 11th, 2010, 05:49 PM
gsynaptics worked as a sharp!

Thanks guys!