PDA

View Full Version : [ubuntu] [SOLVED] Trackpad spaz



Crayboff
September 11th, 2008, 01:19 AM
I just installed Ubuntu 8.04.01 (Hardy Heron) on my Dell Inspiron 1521. I got CompizConfig and turned on Desktop Cube, Expo and Rotating Cube. It was working perfectly. Unfortunately, literally just a couple minutes ago, I downloaded FirstClass (an email client for my school) which shouldn't mess with anything and I moved my mouse and must of touched the scroll portion of my touchpad and it switched workspaces. I checked Keyboard Shortcuts and CompizConfig, but I can't find any reason for this to be happening all of the sudden. This didn't happen before and it is getting very annoying. Is there anyway for a noob like me to stop it from switching workspaces every time i touch the scroll part of my touchpad? :confused:

rossjman1
September 11th, 2008, 01:28 AM
If you scroll on the desktop it automatically switches desktops, I'm not at a GNOME computer, so I don't know exactly were the option is to disable the feature.

Crayboff
September 11th, 2008, 01:31 AM
Ah, well atleast it's not just a recent thing, but does anyone know how to disable that feature?

rossjman1
September 11th, 2008, 01:39 AM
Try looking in the Compiz Settings Manager.

Crayboff
September 11th, 2008, 02:05 AM
I did, I can't find anything determining the scroll function to act as a shortcut.

rossjman1
September 11th, 2008, 02:36 AM
You can disable touchpad scrolling completely by going to System > Preferences > Mouse > Touchpad, but I'll look for the desktop switching setting.
Couldn't find it, but found a workaround here: https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/150443

If you load compizConfig and then unselect the viewport switcher plugin, the desktop switching will start working with the mousewheel.
So, enabling the viewport switcher plugin in Compiz will override GNOME's default setting.

Crayboff
September 11th, 2008, 03:50 AM
Oh dang, it worked. \\:D/

For future reference here is what happened:

Problem: When I hovered my cursor over the desktop and I touched the scroll on my touchpad, it switched workspaces.

Solution: Open CompizConfig and select Preferences. Click the Plugin tab and unselect auto plugin sorting. Find "vpswitch" and move it to the disabled plugin list. That worked for me.
**I do not know if this will cause any backfires and I sure hope it doesn't screw up my computer in any way**

:guitar:

Crayboff
September 11th, 2008, 03:54 AM
Update: just found this site https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/175986 which talks all about this problem.