PDA

View Full Version : [ubuntu] TCPsocket problem in getting clamd running under Thunderbird



thane1
September 10th, 2008, 12:23 AM
Ubuntu 8.04 -64 Have been trying to get clamAV running in Thunderbird and have installed clamdrib from the Mozilla add-ons site, which is supposed to enable clamav/Tbird virus checking (I know I probably don't need it for my linux useage -- I just want to protect Windoze friends from forwarded Windoze emails.) The problem is the /etc/clamav/clamd.conf file apparently (according to an anonymous 8.04 user who has gotten it running) needs the default unix socket disabled by adding the following two lines to the conf file, TCPsocket 3310
TCPAddr localhost Then the installation supposedly works. Have tried this and it doesn't work for me though. Entering clamd in Terminal gives the following line 4 error msg, which I've followed with the contents of my clamd.conf file.
thane@thane-desktop:~$ clamd
ERROR: Parse error at line 4: Unknown option TCPsocket.
ERROR: Can't open/parse the config file /etc/clamav/clamd.conf

thane@thane-desktop:~$ cat /etc/clamav/clamd.conf
#Automatically Generated by clamav-base postinst
#To reconfigure clamd run #dpkg-reconfigure clamav-base
#Please read /usr/share/doc/clamav-base/README.Debian.gz for details
TCPsocket 3310
TCPAddr localhost
LocalSocket /var/run/clamav/clamd.ctl
FixStaleSocket true
User clamav
AllowSupplementaryGroups true
ScanMail true
ScanArchive true
ArchiveMaxRecursion 5
ArchiveMaxFiles 1000
ArchiveMaxFileSize 10M
ArchiveMaxCompressionRatio 250
ArchiveLimitMemoryUsage false
ArchiveBlockEncrypted false
MaxDirectoryRecursion 15
FollowDirectorySymlinks false
FollowFileSymlinks false
ReadTimeout 180
MaxThreads 12
MaxConnectionQueueLength 15
StreamMaxLength 10M
LogSyslog false
LogFacility LOG_LOCAL6
LogClean false
LogVerbose false
PidFile /var/run/clamav/clamd.pid
DatabaseDirectory /var/lib/clamav
TemporaryDirectory /tmp
SelfCheck 3600
Foreground false
Debug false
ScanPE true
ScanOLE2 true
ScanHTML true
DetectBrokenExecutables false
MailFollowURLs false
ArchiveBlockMax false
ExitOnOOM false
LeaveTemporaryFiles false
AlgorithmicDetection true
ScanELF true
IdleTimeout 30
MailMaxRecursion 64
PhishingSignatures true
PhishingScanURLs true
PhishingRestrictedScan true
PhishingAlwaysBlockSSLMismatch false
PhishingAlwaysBlockCloak false
DetectPUA false
LogFile /var/log/clamav/clamav.log
LogTime true
LogFileUnlock false
LogFileMaxSize 0
For the life of me I have no idea how to sort out this lack of/conflict of TCP socket to get clamd running on bootup - in the initd file I think. The aforementioned (in the conf file) readme file doesn't seem to shed any light either.) The TCPsocket value of 3310 is referred to in more than one clamdrib review and is the default socket in the automatic reconfiguration feature of clamd (initiated by the command dpkg-reconfigure clamav-base Any suggestions would be appreciated. TIA

thane1
September 11th, 2008, 12:13 PM
Solved :) I responded to another thread and was helped immeasurably. Please see http://ubuntuforums.org/showthread.php?p=5557815 for the thread.

r_avital
November 21st, 2009, 02:17 AM
FYI all,

The Wiki page on scanning email (https://help.ubuntu.com/community/ScanningEmail#preview) states that you should add "TCPsocket 3310) to the clamd.conf file

I don't know if this is something that has changed since that page was written, but this had me running around in circles for an hour, including full removal/reinstall of clamav as suggested in the linked thread (above), and the dpkg-reconfigure steps etc.

The correct entry is "TCPSocket 3310" (without quotes) - Upper-Case "S"

Hope this helps :)

gnosoz
April 8th, 2010, 02:59 PM
Great!!
much appreciated :)