View Full Version : [ubuntu] GNOME is Broken

September 9th, 2008, 09:46 PM
Basically, I went into my default GNOME session and it was broken. The desktop was a black box. There was a white box where Conky was supposed to be and the AWN dock at the bottom was also messed up.

And when I booted into another session and ran Nautilus from terminal, I got this error:

nautilus: symbol lookup error: nautilus: undefined symbol: g_file_query_filesystem_info_async

I was also looking around in Google once it stopped working and I found this link:


locate glocalfile.c
brought up nothing.

September 9th, 2008, 09:50 PM
have you tried using metacity instead of compiz/awn?

have you tried reinstalling nautilus

September 9th, 2008, 09:54 PM
Reinstalling Nautilus, yes.

Using Metacity instead of Compiz/AWN, I'm too idiotic to know how.

September 9th, 2008, 09:55 PM
in terminal type

metacity --replace

also try removing Conky and AWN then reinstalling

September 9th, 2008, 10:51 PM
in terminal type

metacity --replacealso try removing Conky and AWN then reinstalling
Wait, doesn't metacity --replace replace the current manager?

Which means I'd need to type it in GNOME?

But I'll try it in Failsafe Terminal then GNOME.

September 9th, 2008, 11:03 PM
At the login screen, press Ctrl, Alt and F1, then login from the shell prompt.
Now, you can reset gnome by typing:

rm -rf .gnome .gnome2 .gconf .gconfd .metacity

Now, login normally and the settings will have been reset.

September 9th, 2008, 11:54 PM
That only broke things more. xP