View Full Version : [ubuntu] [SOLVED] Pidgin problems

September 9th, 2008, 01:00 PM
So I am trying to install pidgin and I have had 6 problems so far. 5 I have managed to solve, but the sixth solution is eluding me.
Heres what I get.

XScreenSaver extension development headers not found.
Use --disable-screensaver if you do not need XScreenSaver extension support,
this is required for detecting idle time by mouse and keyboard usage.

Any help?

September 9th, 2008, 01:23 PM
trying installing libxss-dev package.
Pidgin is in the ubuntu repo's and is installed by default if you are using gusty or hardy.

September 9th, 2008, 10:13 PM
I was having the same problem installing Pidgin 2.5.1, but this fixed it.

September 10th, 2008, 03:12 AM
Ok that did fix one problem, but now something else came up. And as painfully obvious as it is after this post, I'm going to say it anyways. I barely have any clue what I am doing.

X session management development headers not found.
Use --disable-sm if you do not need session management support.

I did try Use --disable-sm, and a few others, but I really am bad at this.
And I guarantee this isnt my last post in this thread.

September 10th, 2008, 03:20 AM
maybe try installing libsm-dev package

September 10th, 2008, 03:33 AM
Startup notification development headers not found.
Use --disable-startup-notification if you do not need it.

**** life.

September 10th, 2008, 03:36 AM
install the libstartup-notification0-dev package

September 10th, 2008, 03:45 AM
GtkSpell development headers not found.
Use --disable-gtkspell if you do not need it.

Im sorry for not knowing what I am doing and using up your time, but this is friggen impossible to learn in 2 days.

September 10th, 2008, 03:47 AM
You are not using up my time, happy to help :) for that one install these 2
libaspell-dev libgtkspell-dev

September 10th, 2008, 03:53 AM
Well I am thanking you in every post, and thanks again. I plan on reading the tutorials when I have a break from school and work.

You must have libxml2 >= 2.6.0 development headers installed to build.

September 10th, 2008, 04:17 AM
you need libxml2-dev

Edit: Here are a few more you will need installed

Let me know if you get stuck again.

September 10th, 2008, 04:54 AM
Well I made it a hell of a lot further this time.

Neither GnuTLS or NSS SSL development headers found.
Use --disable-nss --disable-gnutls if you do not need SSL support.
MSN, Novell Groupwise and Google Talk will not work without GnuTLS or NSS. OpenSSL is NOT usable!

Thanks for all of this man.

September 10th, 2008, 05:04 AM
try libnss3-dev

September 10th, 2008, 05:08 AM
try libnss3-dev

There is no package that is called libnss3-dev.

krystle@krystleslaptop:~$ sudo apt-get install libnss3-dev
Reading package lists... Done
Building dependency tree... Done
E: Couldn't find package libnss3-de

September 10th, 2008, 05:30 AM
What version of ubuntu are you using? libnss3-dev is available for feisty, gusty, hardy.

Edit: you may also need to install libgnutls-dev

September 10th, 2008, 06:00 AM
So that was the last one. Oh and I have Ubuntu 6.06 LTS. The reason I had to go through all of this is because they didn't code pidgin for 6. So I had to do this for the first time. But thanks man, I owe ya big time.

September 10th, 2008, 06:02 AM
your welcome :)

September 10th, 2008, 12:05 PM
Ok so I configured it, and then typed in make. Now what do I do? Theres nothing installed but at the same time it must have done something , amirite?

September 10th, 2008, 12:21 PM
If make passed with no errors
install it with

sudo make install

September 10th, 2008, 12:50 PM
If make passed with no errors
install it with

sudo make install

Thanks again man. I'm pretty sure that's all I need.

January 14th, 2011, 04:53 AM
i have same problem.
i disable something when configure them
i need to enable it

tito@tito:~/Downloads/pidgin-2.7.9$ ./configure --disable-screensaver --disable-startup-notification --disable-gtkspell --disable-gstreamer --disable-vv --disable-idn --disable-meanwhile --disable-avahi --disable-nm --disable-perl --disable-nss --disable-gnutls --disable-tcl

what should i install before configure pidgin?