View Full Version : [gnome] [SOLVED] Restarting X results in blank screen.

September 7th, 2008, 03:42 AM
Like the title says, sometimes (but not every time) using CTRL+ALT+Backspace results in a blank screen. I can't get a virtual terminal or gdm. I've tried dropping to a terminal with Ctrl+Alt+F1, and even though I don't get a prompt I log in and attempt to "sudo shutdown now". Nothing. The only fix I've found so far is a hard reset, which I don't like doing.

Any hints/ideas?

September 7th, 2008, 06:17 AM
Looks like the problem is a cause by the x server.Type:

sudo gedit /etc/X11/xorg.conf

Post your results so we can see what might be wrong

September 7th, 2008, 06:25 AM
# xorg.conf (X.Org X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"

Section "Device"
Identifier "Configured Video Device"
Driver "fglrx"

Section "Monitor"
Identifier "Configured Monitor"

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
Inputdevice "Synaptics Touchpad"
Section "Module"
Load "glx"

September 7th, 2008, 06:37 AM
It seems that your that you have a fglrx driver installed.I think that might cause the blank screen.Reconfigure your x config by typing

dpkg-reconfigure xserver-xorg

Choose vesa as your driver.Then type

dpkg-reconfigure gdm

Restart X then tell me if anything happens.

September 7th, 2008, 06:52 AM
Restart X then tell me if anything happens.

Something happened...

...It works! Thanks!