PDA

View Full Version : [ubuntu] 8.04 install fails on fdd0 I/O error



gforcing
September 6th, 2008, 11:42 PM
Hello all,

I'm trying to install Ubuntu 8.04 (Hardy Heron) on a desktop computer with the following setup:

250GB Maxtor HDD (SATA) with Windows Vista Ultimate
750GB Seagate HDD (SATA) - just a storage drive
4GB Corasair DDR2 RAM
Blu-ray ROM /DVDRW & CDRW Burner (SATA)
AMD Athlon 5600+
Gigabyte SLI motherboard
XFX nVidia 8800GT

Whenever I try to install Hardy, or even to start Ubuntu from the Live CD, I get an error message which says that there is a problem with fdd0. This doesn't make any sense, because nothing - absolutely nothing - is plugged in to the floppy disk drive slot.

I've installed Ubuntu dozens of times on other machines (and this machine, actually, but with XP instead of Vista and a different motherboard) and I've never had any error like this.

Please help!

-- EDIT --
Here's the actual error:


Buffer I/O error on device fd0, logical block 0

There are a couple of threads on this forum already dealing with this error, but so far nothing has worked. I think it could be the Blu-Ray player, I'm going to try using an old IDE CD/DVD drive.

Partyboi2
September 7th, 2008, 12:36 AM
You could try adding
all_generic_ide as a boot option. At the main menu press F6 and and it to the end of the line.

gforcing
September 7th, 2008, 09:47 PM
Alright, your advice worked. But now I have a different problem.

Because I'm installing Ubuntu AFTER Vista, I can't figure out how to boot into Grub. I tried using a program called EasyBCD (version 1.7.2) but I can't get that to work at all. I followed the tutorial on their site and everything.

Any suggestions?

Partyboi2
September 8th, 2008, 09:53 AM
Try restoring grub using the live cd, you can follow this guide (http://ubuntuforums.org/showthread.php?t=224351)