PDA

View Full Version : [ubuntu] 810 chipset driver issue !!!



xtrememertx
September 6th, 2008, 09:14 AM
Hey Guys ,

I'm having trouble while watching youtube videos and playing games like bzflag .

I get around 5-10 fps per seconds while watching youtube videos and i can't even move the mouse cursor properly in bzflag .

I had no problem playing counter strike 1.6 and watching youtube videos on xp .

Here are my system specs :

celeron 466 mhz
384mb ram
810 chipset
xubuntu Desktop on Ubuntu hardy heron

Here is my xorg.config


# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
# sudo dpkg-reconfigure -phigh xserver-xorg
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection

Section "Device"
Identifier "Configured Video Device"
Boardname "vesa"
Busid "PCI:0:1:0"
Driver "i810"
Screen 0
EndSection

Section "Monitor"
Identifier "Configured Monitor"
Vendorname "Samsung"
Modelname "Samsung Samtron 55v"
Horizsync 30-55
Vertrefresh 50-120
modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
modeline "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
modeline "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
modeline "640x480@85" 36.0 640 696 752 832 480 481 484 509 -vsync -hsync
modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
modeline "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
modeline "800x600@85" 56.3 800 832 896 1048 600 601 604 631 +hsync +vsync
modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
modeline "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
modeline "1024x768@43" 44.9 1024 1032 1208 1264 768 768 776 817 +hsync interlace +vsync
Gamma 1.0
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
Defaultdepth 24
SubSection "Display"
Depth 24
Virtual 1024 768
Modes "1024x768@60" "1024x768@43" "832x624@75" "800x600@60" "800x600@85" "800x600@75" "800x600@72" "800x600@56" "640x480@85" "640x480@75" "640x480@72" "640x480@60"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "Default Screen" 0 0
EndSection
Section "Module"
Load "glx"
Load "GLcore"
Load "v4l"
EndSection
Section "ServerFlags"
EndSection


And when i enter glxinfo | grep direct in terminal i get



direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
OpenGL renderer string: Mesa GLX Indirect



Thank you

NT4usB
September 6th, 2008, 05:22 PM
Do you know your way around the command line?
Couple things to try.
Edit xorg.conf and change:
Driver "i810"
to
Driver "intel"
See if that helps.

Also, might try changing:
SubSection "Display"
Depth 24
to
SubSection "Display"
Depth 16

xtrememertx
September 6th, 2008, 09:27 PM
I edited the things you told me to in xorg.conf by sudo gedit /etc/X11/xorg.conf and rebooted .

There is still no difference :(

NT4usB
September 7th, 2008, 02:27 AM
ratz...
Would have been nice if it was that easy.
I did a quick google on it and there's plenty of reading in the subject.
http://www.google.com/search?hl=en&q=site%3Aubuntuforums.org+intel+i810+video+driver+ hardy&btnG=Google+Search

xtrememertx
September 7th, 2008, 08:33 AM
Thx for the reply !!!

I changed the default depth to 16 and this enabled direct rendering .
But there is still no increase in performance except when i run glxgears .

I tried running bzflag , now the colours are horrible ..its almost unplayable but its a bit faster than the previous config .

There is still no increase in performance of flash .

My glxgears fps is just about 200 !!!!

xtrememertx
September 9th, 2008, 06:19 AM
BUMP sorry

xtrememertx
September 12th, 2008, 06:12 AM
Anybody plz !!!:sad: