PDA

View Full Version : Eclipse- Running error



Rany Albeg
August 27th, 2008, 05:09 PM
Hi,

I wanted to test eclipse so i wrote a simple project which prints the word
"hi" on the screen.

I've selected the "Managed make c++ project" option so i wont have to deal with the makefile at this time.

When i run the project i get a message: "An internal error occurred during "Launching"

need some help

thanks.

MarkieB
August 27th, 2008, 05:23 PM
no longer participating in ubuntuforums.org

Rany Albeg
August 27th, 2008, 06:16 PM
installation = sudo apt-get install eclipse eclipse-cdt

and the "program":

#include <iostream>
using std::cout;
int main()
{
cout<<"hi";
return 0;
}

the empty line after '}' is also included in the cpp file.

i'll be happy for some help.

mike_g
August 27th, 2008, 06:27 PM
Well your code is correct. Unfortunately the error message is not very descriptive. My best guess is that you may need to link g++ to the IDE. Or, at least you have to do that with Netbeans; never used Eclipse myself.

mike_g
August 27th, 2008, 06:30 PM
Well your code is correct. Unfortunately the error message is not very descriptive. My best guess is that you may need to link g++ to the IDE. Or, at least you have to do that with Netbeans; never used Eclipse myself.

Edit: If you havent already done it you might have to set up the headers and stuff:

sudo aptitude install build-essential

Oops double post o_O

Rany Albeg
August 27th, 2008, 07:00 PM
Thanks markieB ,mike_b

the problem is solved :

1) open console and install build essential
'sudo apt-get install build-essential'

2) add the line 'Debug/project_name' as shown in the picture i added.

MarkieB
August 27th, 2008, 07:02 PM
no longer participating in ubuntuforums.org

Rany Albeg
August 27th, 2008, 09:41 PM
Yea , thanks again.