PDA

View Full Version : [ubuntu] How do I always print in black and white?



feedmecereal
August 26th, 2008, 02:37 AM
With my old printer, I just went to the "Printers" window, right-clicked, clicked on "Properties," click "Advanced," and then changed to color model to black and white. With my new printer, I can only select RGB color model.

How to I get my printer to always print in black and white system-wide?

rax_m
August 27th, 2008, 08:49 PM
Normally you go to System->Administration->Printing. Choose your printer and under some of the options, perhaps Printout mode you may see the option to set it to greyscale.
Of course I'm not sure if this varies with different printers. Which printer do you have?

prshah
August 27th, 2008, 11:06 PM
How to I get my printer to always print in black and white system-wide?

Open the CUPS admin page in a browser:
http://127.0.0.1:631, then click "Manage Printers", then, under the concerned printer's heading, click "Set printer options" (you may have to scroll to the right side), then, under "Color Model", choose "Greyscale".

feedmecereal
August 28th, 2008, 12:03 AM
The color model is set to RGB and there are no other options to select. I am using a Canon MP210.

prshah
August 28th, 2008, 07:42 AM
The color model is set to RGB and there are no other options to select. I am using a Canon MP210.

Can you post a screenshot, with the combo box for "color model" open, so that we can see what options are available? Open up the CUPS page, navigate to your printer settings page, then use Applications-Accessories-Take Screenshot, set a delay of 5 (?) seconds, click OK/Take screenshot, click the color model combo box to open it, and wait for the screenshot to be taken; you will be prompted for a save filename when done.

Please upload that file here.

feedmecereal
August 28th, 2008, 12:47 PM
Here you go. It only shows RGB.

BXCracer
August 28th, 2008, 02:29 PM
I have the very same printer and problem, maybe canon is lazy enough ant they havent added support for grayscale printing for linux. I think we have to write to canon and ask to update drivers

Edit: I found the solution. Instead of the mp210 printer driver use Canon PIXMA MP150 - CUPS+Gutenprint. This driver will allow you to print grayscale