View Full Version : [ubuntu] Need help fixing hardy boot

August 25th, 2008, 03:18 AM
Hey guys, I've finally run into a snag with ubuntu. Somehow my /boot directory was deleted. I copied the /boot directory off the livecd onto the old root dir and rerun the grub setup, but no dice. startup snags at "waiting for root filesystem" The old kernels are still in the modules directory, but I don't know how to direct grub to use that. I've tried to boot from the livecd and chroot over to my old one and rebuild the kernel, but I get errors when installing. I also can't use apt-get update (after chroot) because it is unable to resolve any of the repositories even though I am on the internet. I've also tried redownloading the files needed to rebuild the kernel; but the installation fails.

I'm somewhat new to this area of linux so I'm sure there is an easier way to do things. Any help would be appreciated..Thanks

I'm on hardy, I was previously running the intrepid kernel (2.6.26-2)

August 26th, 2008, 07:29 AM
I tried to find out which package the files in /boot are in, and only the kernel images and memtest86+ packages have any files there. So I guess the stuff in /boot/grub is all autogenerated?

Is the filesystem error from the kernel or grub?

Here is an example entry from menu.lst, maybe you can use this to get going.

title Ubuntu 8.04.1, kernel 2.6.24-19-generic
root (hd0,0)
kernel /vmlinuz-2.6.24-19-generic root=/dev/md1 ro quiet splash
initrd /initrd.img-2.6.24-19-generic

Also look at https://help.ubuntu.com/community/GrubHowto