PDA

View Full Version : [ubuntu] IBM X31 Ati Mobility Radeon M6 LY - HOW TO ENABLE 3D



coorior
August 24th, 2008, 08:46 AM
Ok guys , it's my first post and i'm still newbie in Linux world , so please forgive me for any mistakes i make . also i'm not a native english speaker , but i will try my best , fell free to correct me ..
to business ,, i have an old laptop IBM X31 with ATI MOBILITY RADEON M6 LY . i have been trying to enable my graphic card very long time , there is few treads on how to do it , but it didn't work on my computer . most of how-toes are too complicated for newbies like myself . i found this how to on chinese ubuntu forums ( http://forum.ubuntu.org.cn/viewtopic.php?t=127472&sid=1da966168cfa6f7da187dc488b88ac9c ) written by zishanchen , so all thanks should go to him . as i study and live in china wanted to translate it to you .
NOTE: this how-to is very simple , just copy and paste procedure . without any descriptions so you will not get confused .


this how-to was written for IBM X31 . if you want to try it on other computer with the same graphic card , do it at your own risk . on my computer it worked perfectly .



1. first restart your computer .

2. update your system (in terminal)

sudo apt-get update
sudo apt-get upgrade

3. in terminal enter

lspci | grep ATI

output must be "ATI Technologies Inc RadMobility M6 LY"
if it is please proceed , if not stop here .

4. if you installed fglrx you should stop it, it can be done by accessing system > administration > hardware drivers stop it from there and restart your computer again .

5. in terminal enter

glxinfo | grep vendor

if output is :

server glx vendor string: SGI
client glx vendor string: SGI
OpenGL vendor string: Tungsten Graphics, Inc.

you are ready to proceed .

6. terminal :

sudo apt-get remove xorg-driver-fglrx
sudo apt-get install libgl1-mesa-glx libgl1-mesa-dri

restart.

7. we have to configure xorg now .(first backup your xorg ! )
in terminal :

sudo dpkg-reconfigure xserver-xorg
sudo gedit /etc/X11/xorg.conf

now replace your xorg.conf with the one below


##########################################
## xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection


Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "Device"
Identifier "ATI Technologies Inc Radeon Mobility M6 LY"
Busid "PCI:1:0:0"
Driver "radeon"
Option "AGPSize" "32"
Option "XAANoOffscreenPixmaps" "on"
Option "AGPMode" "4"
Option "AGPFastWrite" "on"
Option "DisableGLXRootClipping" "on"
Option "AddARGBGLXVisuals" "on"
Option "AllowGLXWithComposite" "on"
Option "EnablePageFlip" "on"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies Inc Radeon Mobility M6 LY"
Monitor "Generic Monitor"
DefaultDepth 16
SubSection "Display"
Depth 8
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "Default Screen" 0 0
Inputdevice "Generic Keyboard"
Inputdevice "Configured Mouse"
Inputdevice "Synaptics Touchpad"
option "AIGLX" "true"
EndSection

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection
#######################################

now safe > exit > restart your computer

8. in terminal :

sudo glxinfo | grep direct

output should be
“direct rendering: Yes”
if it is "yes" then you did everything right !!!
if not - STOP , don't go any further . check if you did everything right .


9. now we have to configure compiz
system > preferences > appearance set visual effects to "none"
in terminal :

sudo apt-get autoremove compiz

10.install compiz-fusion
first in terminal :

sudo gedit /etc/apt/sources.list

at the bottom of the list add this lines :

deb http://download.tuxfamily.org/3v1deb feisty eyecandy
deb-src http://download.tuxfamily.org/3v1deb feisty eyecandy

again in terminal type :

sudo apt-get update
sudo wget http://download.tuxfamily.org/3v1deb/DD800CD9.gpg -O- | sudo apt-key add -

11. sudo apt-get install compiz compiz-gnome
sudo apt-get install compizconfig-settings-manager
sudo apt-get install compiz-fusion-* emerald-themes

12. sudo apt-get install git git-core compiz-dev
git-clone git://anongit.opencompositing.org/users/crdlb/fusion-icon
cd fusion-icon
make
sudo make install

13. YOU ARE ALMOST FINISHED !!!
now you have to add fusion-icon which you just have installed to sturtup
system > preferences > sessions click "add" and in "command" line add "fusion-icon"
AND NOW YOU ARE FINISHED . JUST RESTART YOUR BEAUTIFUL X31 AND YOU WILL SEE FUSION ICON ON THE PANEL .. JUST RIGHT CLICK ON IT AND YOU WILL BE ABLE TO CHANGE YOUR BEAUTIFUL HARDY DESKTOPS WINDOW MANAGER TO COMPIZ !!!!!!!!!!!!!!!!!!!

happy compizing :)

bchapman
November 12th, 2008, 03:57 AM
Thanks! This was very helpful! For those folks who want to be able to click and scroll using the pointing stick, you could add this to the xorg.conf:

Option "EmulateWheel" "true"
Option "EmulateWheelButton" "2"This needs to go in the InputDevice section of the xorg.conf.

EDIT: 1/2009 - xorg.conf no longer controls settings like this. You will need to edit one of the XML files that is read by HAL. See this post for a suggested configuration: http://oprisan.wordpress.com/2008/11/02/ubuntu-810-middle-button-scrolling-for-ibm-lapotops-trackpoints/

Rogbert
January 9th, 2009, 07:09 PM
Has anyone made this work on 8.10 Intrepid Ibex? I just upgraded and love it, but my frame rate is too slow to do much with compiz.

vtdstein95
January 10th, 2009, 02:20 PM
Confirming this method works fine on a Thinkpad T42 with ATI Radeon Mobility Firegl 9000 (RV250). Compiz worked wonderfully in Gusty. I have been running Hardy for 6+ months now without compiz, util I tried this guide.

Thank You!!

Rogbert
January 11th, 2009, 05:47 PM
hmmm...ran it on my x31 and speeds up the framerate, etc. but then i lose my window decorations (title bars), my awn dock and my screenlets (all white). Restore my xorg and back to normal. Can get compiz working like this but REALLY painfully slow. Any good ideas out there?

Dr.Suave
February 24th, 2009, 08:38 PM
I tried this with Intrepid, and lost my window decorations and some desktop functionality when I enabled Compiz using the compiz icon. If anyone else tries this tutorial, I would test to see if it works by pressing alt+f2 and entering "fusion-icon" before carrying out step 13. If compiz breaks your desktop, you can just ctrl+alt+backspace, and everything will be ok again.

dreamylinux
July 19th, 2009, 04:32 AM
maybe you whould like to check this out: its mentioning about hyperz, hyperz is for accellaration

"..Radeon LE- Radeon "Light Edition". I'm not sure if that is really what LE stands for, but that's what most people claim. Not officially manufactured by ATI, but instead by a partner company. There are no ATI logos on the card (just blank white spaces where they would be). Nonetheless, it is a Radeon card and uses the same drivers as all other cards. By default Hyper-Z is disabled on this card, but all you have to do to reenable it is download a registry tweaker (or just tweak the registry directly). It is also clocked lower at 143/143 MHz, BUT the memory is the same so you can clock it back up to 185 MHz or so with no problems. This card is available for around $80 and runs as fast as the GF2 GTS. The best buy for your money!
.."
here is the link, it says alot of things

http://www.ocforums.com/showthread.php?t=9641

pirmas
November 8th, 2009, 12:06 AM
Hello, everyone,

I'm new here, so sorry for any mistakes I would probably make when participating in this forum.

I'm coming straight to the point:

Today I have installed ubuntu 9.10. And by default there was set "normal" visual effects option, which was n ot, quite good, for my ibm x31 video card (ATI Mobility RADEON M6C-16h - the same as m6 LY mentioning in this topic). The screen was pixelated, etc. I had turned off those effects, but the problem was not fully solved. Here's what I mean:

http://img36.imageshack.us/img36/2320/systemmonitor.png
That's how system monitor windows looks like.

And google earth:

http://img266.imageshack.us/img266/6540/screenshotgoogleearth.png

nice, right?

However, there no any other problems, the system is really fast, there's no lag, etc. just those problems that I mentioned above.

Can anyone tell me where should I start solving the problem? what's the first step? modifying xorg.conf? But I'm afraid not to "modify" too much... I could post any log files, or mentioned xorg.conf, or any other, if that would help to solve the problem.

I'm in love with the new ubuntu, and don't wanna stay with this issue ;)

Thanks in advance for a help!

pirmas
November 8th, 2009, 12:49 PM
Can I have anybody's attention here? Or is it very complicated thing to fix? :(

killerbeesateme
November 8th, 2009, 05:22 PM
Hello, everyone,

I'm new here, so sorry for any mistakes I would probably make when participating in this forum.

I'm coming straight to the point:

Today I have installed ubuntu 9.10. And by default there was set "normal" visual effects option, which was n ot, quite good, for my ibm x31 video card (ATI Mobility RADEON M6C-16h - the same as m6 LY mentioning in this topic). The screen was pixelated, etc. I had turned off those effects, but the problem was not fully solved. Here's what I mean:

http://img36.imageshack.us/img36/2320/systemmonitor.png
That's how system monitor windows looks like.

And google earth:

http://img266.imageshack.us/img266/6540/screenshotgoogleearth.png

nice, right?

However, there no any other problems, the system is really fast, there's no lag, etc. just those problems that I mentioned above.

Can anyone tell me where should I start solving the problem? what's the first step? modifying xorg.conf? But I'm afraid not to "modify" too much... I could post any log files, or mentioned xorg.conf, or any other, if that would help to solve the problem.

I'm in love with the new ubuntu, and don't wanna stay with this issue ;)

Thanks in advance for a help!

I have an X32, and had the same problem with NX Client from NoMachine, and the right click menu in Firefox. I didn't have an xorg.conf from the default install, so I just made one with the same contents as the first post suggested. I rebooted, and enabled "Normal Effects" and so far I haven't had any glitches and my NX Client runs without a hitch.

Arch linux pushed an x server update that caused this same behavior about 1-2 weeks ago so to me it seems like something changed upstream requiring a reworking of the xorg.conf. I wish I found this before switching from Arch to Ubuntu so I could find the magic lines in the config file that fixed this.

pirmas
November 9th, 2009, 12:19 AM
I have an X32, and had the same problem with NX Client from NoMachine, and the right click menu in Firefox. I didn't have an xorg.conf from the default install, so I just made one with the same contents as the first post suggested. I rebooted, and enabled "Normal Effects" and so far I haven't had any glitches and my NX Client runs without a hitch.

Arch linux pushed an x server update that caused this same behavior about 1-2 weeks ago so to me it seems like something changed upstream requiring a reworking of the xorg.conf. I wish I found this before switching from Arch to Ubuntu so I could find the magic lines in the config file that fixed this.

Thank you for your reply. I've been reading forums/other tutorials, and experimenting the whole day today, aand...well, finally noticed, that my xorg.conf has gone :shock: the X11 just didn't inclue xorg.conf...and as you said, than I made it on my own, by pasting the mentioned contents from this topic...and nothing changed actually. The results are the same as I posted screenshots early (when effects are turned off), BUT when I turned on effects to "normal" option, the effects started to work without crash (just after ubuntu install yesterday, effects were also ok, but the system crashed for a few times, forcing me to turn off those effects). However, Now I write with enabled effects, but still there are some glitches:

http://img42.imageshack.us/img42/9514/screenshotubuntuforumsr.png
As you see - there are visual stripes on firefox, as on any other program or folder.

http://img194.imageshack.us/img194/9532/20091109.jpg

..And when started the video test - the results are also "striped".

Didn't try google earth, because had uninstalled it, but I guess nothing would have changed.

Conclusion? Buy new hardware? netbook maybe? I lost my last hope to repair this :frown:

Prosthetic Head
November 9th, 2009, 02:01 AM
I have exactly this problem on an X32, the most annoying feature is the heavy striping on video playback.. If i ever find a solution then i will post back here but I've been trying for a while so don't hold your breath.

Anyone else can help us? A lot of people still have these great little laptops and this pretty much rules out any serious use of ubuntu. This would be great to get fixed.. I'm willing to put in some time and effort but beyond what I have already tried I don't know where to start.

pirmas
November 9th, 2009, 11:36 AM
I have exactly this problem on an X32, the most annoying feature is the heavy striping on video playback.. If i ever find a solution then i will post back here but I've been trying for a while so don't hold your breath.

Anyone else can help us? A lot of people still have these great little laptops and this pretty much rules out any serious use of ubuntu. This would be great to get fixed.. I'm willing to put in some time and effort but beyond what I have already tried I don't know where to start.

Ah, right, just noticed that when watching video - the active display zone is also striped as in my test screenshot.

Anyway, I think it's Kernel's problem, because when I encountered the first crash, the error message included "kernel" term... Sadly our ibm hardware is quite old and I think it will be difficult to find the solution... :roll:

foureyesboy
November 11th, 2009, 06:21 PM
Hello, everyone,

I'm new here, so sorry for any mistakes I would probably make when participating in this forum.

I'm coming straight to the point:

Today I have installed ubuntu 9.10. And by default there was set "normal" visual effects option, which was n ot, quite good, for my ibm x31 video card (ATI Mobility RADEON M6C-16h - the same as m6 LY mentioning in this topic). The screen was pixelated, etc. I had turned off those effects, but the problem was not fully solved. Here's what I mean:

http://img36.imageshack.us/img36/2320/systemmonitor.png
That's how system monitor windows looks like.

And google earth:

http://img266.imageshack.us/img266/6540/screenshotgoogleearth.png

nice, right?

However, there no any other problems, the system is really fast, there's no lag, etc. just those problems that I mentioned above.

Can anyone tell me where should I start solving the problem? what's the first step? modifying xorg.conf? But I'm afraid not to "modify" too much... I could post any log files, or mentioned xorg.conf, or any other, if that would help to solve the problem.

I'm in love with the new ubuntu, and don't wanna stay with this issue ;)

Thanks in advance for a help!

Pirmas, did you say Visual Effects option has been set to Normal?

I have Radeon Mobility M6 on my X22 too and experience the same problem and we have some discussion here at http://ubuntuforums.org/showthread.php?t=1285406

Basically, if Visual Effects was turned on, this "pixelated" problem is not observed.

But if Visual Effects can't be turned on, then one last resource is to use the vesa driver instead. Please refer to that thread for details.

Hope this may help.

pcblues
November 17th, 2009, 09:13 AM
Hi there.

I have this card in an old Dell c610.
I fixed it by following the directions in this link down to the end of step 8.

http://ubuntuforums.org/showthread.php?t=899178
(http://ubuntuforums.org/showthread.php?t=899178)
/etc/X11/xorg.conf didn't exist for my installation of U910 so I just created it and copied the config in, rebooted and it worked.

Then I set the Appearance settings to Extra and all font/graphic corruption problems went away.
I had them in Wine, the Notification windows, the Activity Monitor and Open Office.

Cheers,

Mark

Vinnie V
February 6th, 2010, 02:23 AM
Hi there.

I have this card in an old Dell c610.
I fixed it by following the directions in this link down to the end of step 8.

http://ubuntuforums.org/showthread.php?t=899178
(http://ubuntuforums.org/showthread.php?t=899178)
/etc/X11/xorg.conf didn't exist for my installation of U910 so I just created it and copied the config in, rebooted and it worked.

Then I set the Appearance settings to Extra and all font/graphic corruption problems went away.
I had them in Wine, the Notification windows, the Activity Monitor and Open Office.

Cheers,

Mark

I am glad that I read all the way to the end of the thread before starting this process. I also have a C610, and was also able to stop at step 8. Question though...is compiz an unnecessary program for this configuration, or just not now? I only set my Appearance settings to Normal.