View Full Version : [ubuntu] "exception Emask" and "Buffer I/O Error"

August 23rd, 2008, 11:44 PM
When I try to run the live CD or install Ubuntu on two different C2D P35 chipset computers, I get the following screen after the screen with the Ubuntu loading bar (see below). I've tried both the 64-bit and x86 builds, two different CD burners, burning to DVD instead of CD, and two different CD drives. It works fine on my Athlon XP computer. The only things I can think of are a conflict with the P35 chipset or SATA CD drives (as opposed to IDE). Any ideas?

I'm pretty sure ata2.00 is referring to my CD drive, because that changed to ata4.00 when I moved the CD drive's sata cable to a different port.

August 24th, 2008, 01:55 AM
Buffer I/O error on device fd0, logical block 0 Refers to the floppy drive. Try disabling the floppy drive in your bios or try adding
nofloppy or
all_generic_ide as a boot option. You can do this by pressing F6 at the main menu and adding it to the end of the line. If none of these work you can try installing with the alternate cd (http://releases.ubuntu.com/8.04.1/) which has worked for some who have had this error.

August 24th, 2008, 02:08 AM
all_generic_ide may cut it, otherwise try using the irqpoll option with the kernel.