PDA

View Full Version : [ubuntu] [SOLVED] monitor resolution problem - no 1920x1200



Tomston
August 23rd, 2008, 06:36 PM
Hi All,
This is my first post, so my apologies if this has already been answered - searched around and found a few similar threads but nothing quite the same as my situation.

I am completely new to Ubuntu - installed 2 days ago and very happy so far, except that my screen resolution (which should be 1920x1200 natively) maxes out at 1680x 1050. I have a Benq G2400W monitor /Nvidia 5750 card.

I am not so good yet with the command line so i'd appreciate it if you spelt out any advice for me so that I can learn how to do stuff.

I have had a crack at editing xorg.conf in the past but with no luck so far.

It currently looks like this:


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Thu Feb 14 18:20:37 PST 2008

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard" "CoreKeyboard"
InputDevice "Configured Mouse"
EndSection

Section "Module"
Load "glx"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
DefaultDepth 24
Option "NoLogo" "True"
SubSection "Display"
Depth 24
Modes "nvidia-auto-select"
EndSubSection
EndSection


I'll be honest, I don't really know what i'm doing. Help!

Thanks in advance,
Tomston.

overdrank
August 23rd, 2008, 06:42 PM
Hi and welcome, have you tried the nvidia-settings? Use the alt, F2 keys and enter the command
gksu nvidia-settings and adjust your resolution there. If they are not installed then you can install via synaptic manager. You may also try and use the command by the same method

gksu displayconfig-gtk and set your resolution there.

SunnyRabbiera
August 23rd, 2008, 06:43 PM
Well you can try the hidden screens and graphics app to help you out here, go into a terminal and type gksu displayconfig-gtk

Tomston
August 23rd, 2008, 06:58 PM
Thanks both of you! Been trying to sort this out for 2 days and now it's sorted within 10 mins of posting!

Simply: i ran the gksu displayconfig-gtk and noticed that i simply hadn't checked the 'widescreen' checkbox. It then showed me 1920 as an option. Just gonna restart machine now but i'm optimistic!

My screen doesn't seem to be listed within the Benq models bit but hopefully, that's academic now.

You guys are this: geniuses.

Thank you!

Tom.

overdrank
August 23rd, 2008, 07:03 PM
Thanks both of you! Been trying to sort this out for 2 days and now it's sorted within 10 mins of posting!

Simply: i ran the gksu displayconfig-gtk and noticed that i simply hadn't checked the 'widescreen' checkbox. It then showed me 1920 as an option. Just gonna restart machine now but i'm optimistic!

My screen doesn't seem to be listed within the Benq models bit but hopefully, that's academic now.

You guys are this: geniuses.

Thank you!

Tom.

Good luck and if next time search the forums and you may be even more amazed :)

Tomston
August 23rd, 2008, 07:21 PM
Gah, actually not out of the woods yet - now I can select 1920 but it doesn't really change the resolution visibly - it sort of makes the desktop size larger than the screen so that when i move my mouse to the corners it scrolls.

Hmm.

overdrank
August 23rd, 2008, 07:23 PM
Gah, actually not out of the woods yet - now I can select 1920 but it doesn't really change the resolution visibly - it sort of makes the desktop size larger than the screen so that when i move my mouse to the corners it scrolls.

Hmm.

Yea I have see this issue. Have you set the resolution in nvidia settings?

Tomston
August 23rd, 2008, 07:28 PM
Ah, right - fixed it!
Went back into displayconfig and switched my monitor (it seems to recognise it now) from analog to digital and rebooted. Everything is crisp and nigh-res and very nice indeed!

Thanks again guys.

:popcorn:

Tomston
August 23rd, 2008, 07:37 PM
Well...again, almost but not quite!

It seems that when my resolution was fixed, Visual Effects got turned off. So I went to appearance to turn it back on and it asked me again if i wanted to enable to nvidia driver. I said yes, rebooted and now my screen is too big again.

Could I be using the wrong Nvidia driver? There seems to be some sort of conflict between the graphics driver and the resolution settings...hmm.

Tomston
August 23rd, 2008, 08:20 PM
Right, now i'm stuck again. Quite simply, I can run 1920 perfectly but only as long as I have my Nvidia driver disabled. I tried checking if I had the wrong one installed by removing the one I had with Envy and letting it detect the correct one. Unfortunately, it's the same story - whenever I enable my Nvidia driver the screen is 'too big'.

Sorry to have thought this was solved several times now (I think i'm evidently over-excitable) but any more thoughts?

Thanks,

Tom.

munkedal
August 24th, 2008, 07:22 AM
I don't know if this will help, but I had the same problem. I had the wrong resolution. I did as mentioned earlier to open the terminal and put in the code, gksu displayconfig-gtk, to bring up the "screen and graphics settings" This is what I was looking for. I set it to "generic monitor" and had to reboot. Then I went back to "monitor resolution settings" and I had so many more resolution choices, I picked one and then I had the same problem of a wide screen that scrolls when the mouse is moved to the side of the screen. I then realised I had the wrong height-width ratio. I picked 1280 X 960 and my screen is perfect.

I hope this helps.

Tomston
August 24th, 2008, 10:41 PM
Thanks for that. That was partly the problem, but I fixed the resolution now. However, I can't seem to get my Nvidia drivers to collaborate with me when i'm in this resolution - I can't enable visual effects, etc. I would guess that now the problem is more to do with the graphics drivers than anything else.

Installing the driver through Envy seems to allow me the right resolution but the graphics card still isn't working properly.

I'm running an Nvidia PCX 5750 and Benq G2400W @1920x1200.

Tomston
August 25th, 2008, 01:54 PM
Please help!

I think the closest to success I can get is by using the Hardware drivers, enable method which allows me to turn on visual effects BUT leaves my resolution goofy and 'too big' for the screen.
I think the problem here is that the gksu displayconfig-gtk screen says I'm running 1920x1200 (which is what I want) and so does the System/Prefernces/Screen Resolution screen. However, the Nvidia X Server Settings screen tells me that I am only running at 1680x1050 (which would explain why I can scroll around the screen).

How the hell do I get the Nvidia X Server settings to let me choose 1920x1200?

Alternately, if I use the Envy method of installing my drivers, I can get the perfect resolution of 1920x1200 but visual effects (and Nvidia X server settings, screensavers, etc.) are not enabled.

Please, please help - this is driving me crazy! This is day 5 without setting up my screen properly - I just want to be able to get on with starting to use Ubuntu!

Tomston.

Tomston
August 25th, 2008, 01:57 PM
By the way, my xorg.conf looks like this, if it's any help:


# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Device"
Identifier "Configured Video Device"
Boardname "NVIDIA GeForce FX (generic)"
Busid "PCI:1:0:0"
Driver "nvidia"
Screen 0
Vendorname "NVIDIA"
Option "NoLogo" "True"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
Vendorname "Generic LCD Display"
Modelname "LCD Panel 1920x1200"
Horizsync 31.5-74.5
Vertrefresh 56.0 - 65.0
modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "1280x768@60" 80.14 1280 1344 1480 1680 768 769 772 795 -hsync +vsync
modeline "1280x720@60" 74.48 1280 1336 1472 1664 720 721 724 746 -hsync +vsync
modeline "1280x800@60" 83.46 1280 1344 1480 1680 800 801 804 828 -hsync +vsync
modeline "1440x900@60" 106.47 1440 1520 1672 1904 900 901 904 932 -hsync +vsync
modeline "1600x1024@60" 136.36 1600 1704 1872 2144 1024 1025 1028 1060 -hsync +vsync
modeline "1680x1050@60" 147.14 1680 1784 1968 2256 1050 1051 1054 1087 -hsync +vsync
modeline "1920x1200@60" 193.16 1920 2048 2256 2592 1200 1201 1204 1242 -hsync +vsync
Gamma 1.0
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24
SubSection "Display"
Depth 24
Virtual 1920 1200
Modes "1920x1200@60" "1680x1050@60" "1600x1024@60" "1440x900@60" "1280x800@60" "1280x720@60" "1280x768@60" "800x600@60" "800x600@56"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "Default Screen" 0 0
EndSection
Section "Module"
Load "glx"
Load "v4l"
EndSection
Section "device" #
Identifier "device1"
Boardname "NVIDIA GeForce FX (generic)"
Busid "PCI:1:0:0"
Driver "nv"
Screen 1
Vendorname "NVIDIA"
EndSection
Section "screen" #
Identifier "screen1"
Device "device1"
Defaultdepth 24
Monitor "monitor1"
SubSection "Display"
Depth 24
Modes "640x480@60"
EndSubSection
EndSection
Section "monitor" #
Identifier "monitor1"
Vendorname "Plug 'n' Play"
Modelname "Plug 'n' Play"
modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
Gamma 1.0
EndSection
Section "ServerFlags"
EndSection

overdrank
August 25th, 2008, 02:03 PM
Hi and have you thought that the graphics card may not be able to handle that resolution?
http://www.nvidia.com/page/fx_5700.html
At the very bottom
Also I was responding as you did and did you add this line to your xorg

modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync

Tomston
August 25th, 2008, 02:13 PM
Hi Overdrank, thanks for replying.

Well, I hadn't considered that, but then again, I had no problems at all doing 1920x1200 when I was using windows so I assume that's not it.

As for that line of code - I didn't add it myself (to be honest I really don't know what i'm doing in xorg.conf so i have left it alone. Also I did a fresh reinstall of Ubuntu about 2 hours ago so it should be relatively untouched.

Does that line of code look out of place? Should I change/remove it?

overdrank
August 25th, 2008, 02:25 PM
Hi Overdrank, thanks for replying.

Well, I hadn't considered that, but then again, I had no problems at all doing 1920x1200 when I was using windows so I assume that's not it.

As for that line of code - I didn't add it myself (to be honest I really don't know what i'm doing in xorg.conf so i have left it alone. Also I did a fresh reinstall of Ubuntu about 2 hours ago so it should be relatively untouched.

Does that line of code look out of place? Should I change/remove it?

Hi and that is a good question and I do not know the answer. It just looks out of place. Is the card PCI or agp, does it require a additional power?
If you have installed the drivers and the nvidia settings, the driver soon in your latest xorg is the nv and not nvidia. So I would say install the drivers under hardware drivers and then look at the xorg then. Then you may need to use the display config to add the resolution there.

Tomston
August 25th, 2008, 02:34 PM
It's a PCI-Express card - the PCX-5750.

Since doing the fresh install, I haven't touched Envy - I just installed directly through hardware drivers and I think maybe then I installed Nvidia settings through synaptic.


I'm sorry but I don't understand what you mean by 'nv and not nvidia', could you explain a little more?

So should I try to reinstall again through hardware drivers? How do i remove it first? Just by disabling it?

Sorry for all the stupid questions - I feel like I'm learning stuff each day but all the command-line stuff seems a far leap from windows so it's taking a little getting used to.

overdrank
August 25th, 2008, 02:47 PM
It's a PCI-Express card - the PCX-5750.

Since doing the fresh install, I haven't touched Envy - I just installed directly through hardware drivers and I think maybe then I installed Nvidia settings through synaptic.


I'm sorry but I don't understand what you mean by 'nv and not nvidia', could you explain a little more?

So should I try to reinstall again through hardware drivers? How do i remove it first? Just by disabling it?

Sorry for all the stupid questions - I feel like I'm learning stuff each day but all the command-line stuff seems a far leap from windows so it's taking a little getting used to.

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Device"
Identifier "Configured Video Device"
Boardname "NVIDIA GeForce FX (generic)"
Busid "PCI:1:0:0"
Driver "nvidia"
Screen 0
Vendorname "NVIDIA"
Option "NoLogo" "True"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
Vendorname "Generic LCD Display"
Modelname "LCD Panel 1920x1200"
Horizsync 31.5-74.5
Vertrefresh 56.0 - 65.0
modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "1280x768@60" 80.14 1280 1344 1480 1680 768 769 772 795 -hsync +vsync
modeline "1280x720@60" 74.48 1280 1336 1472 1664 720 721 724 746 -hsync +vsync
modeline "1280x800@60" 83.46 1280 1344 1480 1680 800 801 804 828 -hsync +vsync
modeline "1440x900@60" 106.47 1440 1520 1672 1904 900 901 904 932 -hsync +vsync
modeline "1600x1024@60" 136.36 1600 1704 1872 2144 1024 1025 1028 1060 -hsync +vsync
modeline "1680x1050@60" 147.14 1680 1784 1968 2256 1050 1051 1054 1087 -hsync +vsync
modeline "1920x1200@60" 193.16 1920 2048 2256 2592 1200 1201 1204 1242 -hsync +vsync
Gamma 1.0
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24
SubSection "Display"
Depth 24
Virtual 1920 1200
Modes "1920x1200@60" "1680x1050@60" "1600x1024@60" "1440x900@60" "1280x800@60" "1280x720@60" "1280x768@60" "800x600@60" "800x600@56"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "Default Screen" 0 0
EndSection
Section "Module"
Load "glx"
Load "v4l"
EndSection
Section "device" #
Identifier "device1"
Boardname "NVIDIA GeForce FX (generic)"
Busid "PCI:1:0:0"
Driver "nv"
Screen 1
Vendorname "NVIDIA"
EndSection




I have highlighted it and that is strange also. One driver is listed a nvidia and the other nv where there should only be one driver. :confused:

Tomston
August 25th, 2008, 05:06 PM
Right - I changed my monitor in gksu displayconfig-gtk to Benq 231 from generic LCD moniotr, and that seems to have changed the xorg.conf so that it matches now:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Device"
Identifier "Configured Video Device"
Boardname "NVIDIA GeForce FX (generic)"
Busid "PCI:1:0:0"
Driver "nvidia"
Screen 0
Vendorname "NVIDIA"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
Vendorname "BenQ"
Modelname "BenQ FP231W (Digital)"
Horizsync 31.0-80.0
Vertrefresh 56.0-76.0
modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
modeline "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "1280x768@60" 80.14 1280 1344 1480 1680 768 769 772 795 -hsync +vsync
modeline "1280x720@60" 74.48 1280 1336 1472 1664 720 721 724 746 -hsync +vsync
modeline "1280x800@75" 107.21 1280 1360 1496 1712 800 801 804 835 -hsync +vsync
modeline "1280x768@75" 102.98 1280 1360 1496 1712 768 769 772 802 -hsync +vsync
modeline "1280x800@60" 83.46 1280 1344 1480 1680 800 801 804 828 -hsync +vsync
modeline "1440x900@75" 136.49 1440 1536 1688 1936 900 901 904 940 -hsync +vsync
modeline "1440x900@60" 106.47 1440 1520 1672 1904 900 901 904 932 -hsync +vsync
modeline "1600x1024@60" 136.36 1600 1704 1872 2144 1024 1025 1028 1060 -hsync +vsync
modeline "1680x1050@60" 147.14 1680 1784 1968 2256 1050 1051 1054 1087 -hsync +vsync
modeline "1920x1200@60" 193.16 1920 2048 2256 2592 1200 1201 1204 1242 -hsync +vsync
Gamma 1.0
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24
SubSection "Display"
Depth 24
Virtual 1920 1200
Modes "1920x1200@60" "1680x1050@60" "1600x1024@60" "1440x900@60" "1440x900@75" "1280x800@60" "1280x768@75" "1280x800@75" "1280x720@60" "1280x768@60" "800x600@60" "800x600@75" "800x600@72" "800x600@56"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "Default Screen" 0 0
EndSection
Section "Module"
Load "glx"
Load "v4l"
EndSection
Section "device" #
Identifier "device1"
Boardname "NVIDIA GeForce FX (generic)"
Busid "PCI:1:0:0"
Driver "nvidia"
Screen 1
Vendorname "NVIDIA"
EndSection
Section "screen" #
Identifier "screen1"
Device "device1"
Defaultdepth 24
Monitor "monitor1"
SubSection "Display"
Depth 24
Modes "640x480@60"
EndSubSection
EndSection
Section "monitor" #
Identifier "monitor1"
Vendorname "Plug 'n' Play"
Modelname "Plug 'n' Play"
modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
Gamma 1.0
EndSection
Section "ServerFlags"
EndSection

The problem still remains though.

Also, for some inexplicable reason, my Pidgin now refuses to open...but i would like to think that has nothing to do with my display drivers!

Tomston
August 25th, 2008, 08:11 PM
It seems that those extra lines of code are created when I go into gksu displayconfig-gtk and try to set my resolution as anything different - like when i try to tell it to run 1920x1200. What I think it's doing is creating a second set of display rules for a second monitor which is disabled. (I don't have 2 monitors connected, but there are options on the screen about it, so maybe that's why?)

I tried deleting the lines and it didn't make any difference. However, I then tried tweaking something else and the system screwed up, and I couldn't restore my old xorg.conf for some reason.

as usual, I did another full reinstall and this time I tried using envy. I'm in almost exactly the same position - xorg.conf looks pretty much the same and only had those extra parts when I changed resolution and screen type in displayconfig-gtk.

I am temporarily running in 1680x1050 (which is okay but slightly glitchy - the title bar of windows turns white and unreadable when i hover over the close button). However, visual effects are running.

I still think the problem must be down to the nvidia x server settings, since I can put my screen as 1920 in displayconfig and in screen resolution BUT in Nvidia Xserver it recgnises my screen as 1680, which is wrong, and explains why my computer thinks i am running 1920 but i am actually running 1680 and scrolling around the extra screen size.

Sorry this is so complicated!

Tomston
August 25th, 2008, 09:50 PM
I don't believe it...

I think the problem is (sort of) fixed - it wasn't the drivers or the hardware - it was the DVI connection....

When I plug in my monitor using VGA connection, I can get 1920x1200 with visual effects perfectly... there must be a bug that means the DVI connection screws up the 1920 signal when visual effects are enabled...

I can't believe that was the solution.
Of course, i would rather my monitor was connected by DVI so i'll have to try to fix that now, but at least I can get on with using Ubuntu now that i have a decent resolution.

I am just doing a fresh reinstall now to confirm that it works properly - I will post a follow-up when it's finished.


Thanks for all your help.

Tomston. (exhausted).

Tomston
August 26th, 2008, 12:04 AM
Yep, works perfectly with a VGA connection rather than DVI.
That's 5 days I'm not getting back, but I'm happy to finally have my basic Ubuntu setup ready to use.